SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Evangelist lance_vincent's Avatar
    Join Date
    Aug 2004
    Location
    philippines
    Posts
    574
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    What wrong with my paragraphs!

    hi guys, would you mind to open this image?

    http://lancevincent.275mb.com/files/

    ok, i have 3 separate <p></p>, but they keep on starting at the same place. any hint why this is happening?

    this is the only weird css part i can think of thats making this
    body,td,th,div,span,ul,ol,li,p,form,table {margin:0;padding:0;font-family:Arial,Helvetica,sans-serif;font-size:12px;}

    what do you think?

    thanks!
    If you won't dress like the
    Victoria Secret girls,
    don't expect us to act like soap opera guys.

  2. #2
    SitePoint Zealot planewalker's Avatar
    Join Date
    Jun 2007
    Location
    Somewhere witty
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, it is an odd way of typing out the style info, but it works fine for me, though you can get the same results this way...

    * {margin:0px;padding:0px;}
    p {font:12px Arial,Helvetica,sans-serif;}

    ...other than that you have some wierd code stuff going on before that so I'm not sure.


    Oh I see, you are just using that page to post the screenshot of what you are seeing. Take the code I posted above and try adding a line height of 18px... like...

    p {font:12px Arial,Helvetica,sans-serif;line-height:18px;}


    But like I said, even using that block of style stuff you had works fine so I'm not sure - can you link to the actual file?

    ---edit---

    Had to update my p code - double check it
    witty comment here...

  3. #3
    SitePoint Evangelist lance_vincent's Avatar
    Join Date
    Aug 2004
    Location
    philippines
    Posts
    574
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi, thanks for the reply, but it doesn't work for me, when i place your code, the whole page looks different.

    anyway, on the code i gave, when i take off "p" from the list, the <p> works just the way im expecting it, im puzzled..

    http://lancevincent.275mb.com/files/country.htm

    please see the location of the css on the page's source.

    thanks for helping!
    Last edited by lance_vincent; Jul 11, 2007 at 22:07.
    If you won't dress like the
    Victoria Secret girls,
    don't expect us to act like soap opera guys.

  4. #4
    SitePoint Zealot planewalker's Avatar
    Join Date
    Jun 2007
    Location
    Somewhere witty
    Posts
    124
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This is doing it...

    p {height:1px;}/*Holly hack for Peekaboo Bug*/

    When removed, there's no issue.
    witty comment here...

  5. #5
    SitePoint Evangelist lance_vincent's Avatar
    Join Date
    Aug 2004
    Location
    philippines
    Posts
    574
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks!

    i solve it 30 minutes ago..but i have to clean my css that was hit my the peekaboo bug though..

    appreciate it man!
    If you won't dress like the
    Victoria Secret girls,
    don't expect us to act like soap opera guys.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •