SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot praveen's Avatar
    Join Date
    Apr 2001
    Location
    Bahrain
    Posts
    108
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP5 session problem on vista

    Hi,

    I have installed php 5.2.3 on IIS7 (vista). Every things work fine except sessions. I have installed php on

    d:\php5\

    and have edited php.ini to point session_save_path to

    d:\php5\sessiondata\ (with full permissions for iuser and inet accounts)

    whenever I access php page using session, php is creating a new sessions ( can see different session id's each time we refresh the page), instead of maintaining the old one.

    I tried the following

    icacls d:\php5\sessiondata\ /grant Users: (CI)(S,WD,AD,X)

    icacls d:\php5\sessiondata\ /grant "CREATOR OWNER": (OI)(CI)(IO)(F)

    but have the same problem. Any idea for fixing this?

    Thanks in advance..

    Pravin

  2. #2
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    This is basicly the reason I stopped using Vista for my development platform and went back to XP.

    I never could figure out why sessions or cookies worked.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  3. #3
    SitePoint Zealot praveen's Avatar
    Join Date
    Apr 2001
    Location
    Bahrain
    Posts
    108
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Finally I got it working

    hi,

    At last I got it working.. here is the fix..

    after going through BillS' IIS Blog

    http://blogs.iis.net/bills/archive/2...-failures.aspx

    and following

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant Users: (CI)(S,WD,AD,X)

    icacls %windir%\serviceprofiles\networkservice\AppData\Local\Temp /grant "CREATOR OWNER": ( OI)(CI)(IO)(F)

    I tried setting no value to the session_save_path, so that it will take the default temp directory..and sessions work fine..

    thank you Bills


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •