SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Jun 2007
    Location
    Kathmandu, Nepal
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    authorized .net payment not working in php...

    I'm using Authorize.net and when I click on the 'order submit' then the following errors have occurred:

    (92) The gateway no longer supports the requested method of integration.

    At first I thought that I was putting the wrong Gateway Username in my Store Settings but Authorize.net has assured me that it's the correct Gateway Username I'm using so now I'm stumped.

    Does anyone know any other reasons why I keep getting this error message?

    Tikaram
    Last edited by Jelena; Jul 5, 2007 at 03:15. Reason: please use your signature for links

  2. #2
    SitePoint Member
    Join Date
    May 2006
    Posts
    22
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    HI friend,

    I'm not a big programmer in this area, but can i know which method you are using for this integration,...AIM or SIM?

    pb

  3. #3
    SitePoint Member
    Join Date
    Jun 2007
    Location
    Kathmandu, Nepal
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have used AIM method for this integration.

    Tikaram

  4. #4
    derrrp
    Join Date
    Aug 2006
    Location
    earth
    Posts
    923
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,

    Could they give you no better help when you told them specifically what your error was?

    It's tough to say without seeing any code, but have you made sure the url you're sending to is correct?

    PHP Code:
    #$auth_net_url    = "https://test.authorize.net/gateway/transact.dll";
    #  Uncomment the line ABOVE for test accounts or BELOW for live merchant accounts
    #$auth_net_url = "https://secure.authorize.net/gateway/transact.dll"; 
    What about your "x_type"?

    PHP Code:
    "x_type" => "AUTH_CAPTURE" 
    I'm just throwing out ideas. I looked the error code up in the manual, which it has but gives no reason why you would get that error.
    No, I REALLY dislike having to use Joomla.

  5. #5
    SitePoint Wizard TheRedDevil's Avatar
    Join Date
    Sep 2004
    Location
    Norway
    Posts
    1,196
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    Authorize.net recently started the work to removed their old intregration method WebLink.

    Most probably that is the method you have been using, or you have not followed the manual when setting up the AIM system.

    If you follow the manual, and does everything correctly AIM will work.

  6. #6
    He's No Good To Me Dead silver trophybronze trophy stymiee's Avatar
    Join Date
    Feb 2003
    Location
    Slave I
    Posts
    23,423
    Mentioned
    2 Post(s)
    Tagged
    1 Thread(s)
    That seems to be the problem. Their manual does explain exactly how to use their API and they even provide sample code that works. Start with that and modify it to suit your needs.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •