SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Member
    Join Date
    Nov 2004
    Location
    Southern California
    Posts
    17
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    PHP Errors in PHPMyAdmin when trying to update value, help a guy out!

    Hey guys, I am trying to update a table's value in phpmyadmin and I keep getting this set of errors when I try:





    Warning: Invalid argument supplied for foreach() in D:\wamp\phpmyadmin\tbl_replace.php on line 209

    Warning: Cannot modify header information - headers already sent by (output started at D:\wamp\phpmyadmin\tbl_replace.php:209) in D:\wamp\phpmyadmin\libraries\header_http.inc.php on line 13

    Warning: Cannot modify header information - headers already sent by (output started at D:\wamp\phpmyadmin\tbl_replace.php:209) in D:\wamp\phpmyadmin\libraries\header_http.inc.php on line 14

    Warning: Cannot modify header information - headers already sent by (output started at D:\wamp\phpmyadmin\tbl_replace.php:209) in D:\wamp\phpmyadmin\libraries\header_http.inc.php on line 15

    Warning: Cannot modify header information - headers already sent by (output started at D:\wamp\phpmyadmin\tbl_replace.php:209) in D:\wamp\phpmyadmin\libraries\header_http.inc.php on line 16

    Warning: Cannot modify header information - headers already sent by (output started at D:\wamp\phpmyadmin\tbl_replace.php:209) in D:\wamp\phpmyadmin\libraries\header_http.inc.php on line 19






    All of the header errors are obviously being caused by the first error so that isn't too important.



    Here are lines 209-221 of tbl_replace.php:

    PHP Code:
            foreach ($me_fields as $key => $val) {

            require 
    './libraries/tbl_replace_fields.inc.php';

            if (empty(
    $me_funcs[$key])) {
                
    $cur_value $val;
            } elseif (
    'UNIX_TIMESTAMP' === $me_funcs[$key] && $val != "''") {
                
    $cur_value $me_funcs[$key] . '(' $val ')';
            } elseif (
    in_array($me_funcs[$key], $func_no_param)) {
                
    $cur_value $me_funcs[$key] . '()';
            } else {
                
    $cur_value $me_funcs[$key] . '(' $val ')';
            } 



    This problem is occouring on my local server which is running wamp4 v1.7.2, which has PHP 5.2.3 and MySQL 5.0.41.

    I searched around for literally a couple hours trying to find a fix but came up empty handed. I am hoping someone else here can help me get this fixed so I can continue working on my project without taking forever to write database changes in SQL format.

    Its also worth noting that I downloaded the latest version of phpmyadmin and it too shared the same exact error message.

    Any help or comments are appreciated!

  2. #2
    We're from teh basements.
    Join Date
    Apr 2007
    Posts
    1,205
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I dumped phpMyAdmin in favor of MySQL's own GUI-based administration and query tools.

    http://mysql.org/downloads/gui-tools/5.0.html

    In general, when a third-party PHP app starts spitting out error messages all over the place, I uninstall it and move on. I consider it a waste of time to try to fix someone else's code.

  3. #3
    SitePoint Evangelist
    Join Date
    Aug 2005
    Posts
    453
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What do you get when you do a var_dump( $me_fields ) ?
    Computers and Fire ...
    In the hands of the inexperienced or uneducated,
    the results can be disastrous.
    While the professional can tame, master even conquer.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •