Is it ok to use reserved words in class method names?

like...

class SomeName {
function SomeName() {}

function insert(...) {}

function delete(...) {}

function find(...) {}
}

Or something different? Any suggestions on naming the standard methods like inserting, updating, deleting, find, etc.