SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Thread: Layout problem

  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Layout problem

    I'm having layout issues in Firefox and can't grasp what I'm doing wrong. It mainly works in IE7.

    The Site
    CSS

    Couple issues:

    1. The right column isn't moving up level with the mood box
    2. In Firefox the background color isn't showing, no clue why.
    3. How do I get the content box to be full length of the page?

    Thank you for any help and if you can help, can you tell me why you fixed what you did. I'm sure here is extra markup, I was adding stuff to try and figure it out.

  2. #2
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    1. If there is space, a floated element will move up to be level with the previously floated element. Each float establishes a new hanging line - that's why your #posts div is lining up with the #linklists div.

    2. Which background colour? The body has a dark-grey background (#161616).

    3. Read the sticky thread at the top of this forum.


  3. #3
    SitePoint Enthusiast
    Join Date
    Oct 2005
    Posts
    98
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'll take a look when I get back home, the background color that isn't showing is the yellow one that shows in IE just not Firefox. The mood isn't in the linklist section because on another layout it is off by itself. Again, thanks for the help and I'll try again later.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •