SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Zealot nwingate's Avatar
    Join Date
    Jan 2004
    Location
    Texas
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    What's wrong with this code?

    Howdy folks,

    Trying to get a new page coded and I keep running into an error.

    The following code gives me an error in my browser and also doesn't swap out the image like it's suppose to.

    <ul style="width: 104px;">
    <li><a class="top_parent" href="/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Category','','/images/nav_on.jpg',1)"><img src="/images/nav_off.jpg" alt="Category" name="Button" width="104" height="23" border="0" id="Button" /></a>
    <ul onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Category','','/images/nav_on.jpg',1)" style="width: 104px;">
    <li><a href="/results.php"><div class="menupad">category</div></a></li>
    </ul>
    </li>
    </ul>
    Any ideas?

  2. #2
    SitePoint Enthusiast mrsmiley's Avatar
    Join Date
    Jul 2004
    Location
    Melbourne
    Posts
    96
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The MM_ functions are Dreamweaver generated javascript. You'd have to post the rest of the page before anyone could help.

  3. #3
    SitePoint Zealot nwingate's Avatar
    Join Date
    Jan 2004
    Location
    Texas
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, every time there is an error it's always with this specific line

    <li><a class="top_parent" href="/" onmouseout="MM_swapImgRestore()" onmouseover="MM_swapImage('Category','','/images/nav_on.jpg',1)"><img src="/images/nav_off.jpg" alt="Category" name="Button" width="104" height="23" border="0" id="Button" /></a>
    The error given is Error: Object Expected and from my end the image doesn't swap out.


    Are you saying there could be another error on the page that causes a problem with this specific line?

    BTW, I'm not doubting you just trying to figure this out. I am NOT a coder. Thanks.
    Last edited by nwingate; May 31, 2007 at 21:24.

  4. #4
    SitePoint Zealot nwingate's Avatar
    Join Date
    Jan 2004
    Location
    Texas
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    BTW, here is the javascript I have in place:

    function MM_swapImgRestore() { //v3.0
    var i,x,a=document.MM_sr; for(i=0;a&&i<a.length&&(x=a[i])&&x.oSrc;i++) x.src=x.oSrc;
    }
    function MM_preloadImages() { //v3.0
    var d=document; if(d.images){ if(!d.MM_p) d.MM_p=new Array();
    var i,j=d.MM_p.length,a=MM_preloadImages.arguments; for(i=0; i<a.length; i++)
    if (a[i].indexOf("#")!=0){ d.MM_p[j]=new Image; d.MM_p[j++].src=a[i];}}
    }
    function MM_findObj(n, d) { //v4.01
    var p,i,x; if(!d) d=document; if((p=n.indexOf("?"))>0&&parent.frames.length) {
    d=parent.frames[n.substring(p+1)].document; n=n.substring(0,p);}
    if(!(x=d[n])&&d.all) x=d.all[n]; for (i=0;!x&&i<d.forms.length;i++) x=d.forms[i][n];
    for(i=0;!x&&d.layers&&i<d.layers.length;i++) x=MM_findObj(n,d.layers[i].document);
    if(!x && d.getElementById) x=d.getElementById(n); return x;
    }
    function MM_swapImage() { //v3.0
    var i,j=0,x,a=MM_swapImage.arguments; document.MM_sr=new Array; for(i=0;i<(a.length-2);i+=3)
    if ((x=MM_findObj(a[i]))!=null){document.MM_sr[j++]=x; if(!x.oSrc) x.oSrc=x.src; x.src=a[i+2];}
    }
    window.onload(MM_preloadImages('/images/nav_on.jpg'));

  5. #5
    SitePoint Zealot
    Join Date
    Nov 2005
    Posts
    113
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Instead of trouble shooting it, why not use DW to remove all the code (or remove by hand) then redo them?

  6. #6
    SitePoint Zealot nwingate's Avatar
    Join Date
    Jan 2004
    Location
    Texas
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well, I paid some guy to do this and he took the money and ran. I've been asking for him to correct the mistake for a month now and I finally gave up.

    I don't know enough to code it myself.

  7. #7
    SitePoint Zealot nwingate's Avatar
    Join Date
    Jan 2004
    Location
    Texas
    Posts
    195
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Figured it out. Path was wrong for the javascript location.

    Thanks for the help.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •