Can anyone help, or point me to someone who can help me get gcc-2.95.3 installed?

Attempting to install MySQL from source code with Redhat Linux 7.1 on my Pentium MMX 234MHz system, I observed a MySQL website compiler advisory which said not to use gcc-2.96 (which comes with Redhat 7.1), but to downgrade to gcc-2.95. I downloaded gcc-2.95.3, uncompressed and unpacked the files. However, following gcc's website directions
http://gcc.gnu.org/install/configure.html
when as root (#) from /usr/local/gcc I typed
# /tmp/download/gcc-2.95.3/configure
I got the following error message:

>>Config.guess failed to determine the host type. You need to specify one.
Usage: configure [OPTIONS] [HOST]
Options: (too many to list here)
Where HOST and TARGET are something like "sparc-sunos",
"mips-sgi-irix5", etc.<<

Their docs say "GCC has code to correctly determine the correct value for 'target' (they seem to interchange this term with 'host')for nearly all native systems. Therefore, we highly recommend you not provide a configure target when configuring a native compiler."

Yet the error message persists.

I have tried combinations of 'options'
(ex. --prefix=/usr/local)
and 'target' or 'host' values
(--target=i586-pc-linux-gnu) and still
come up with the same error message.

I have tried to get help from MySQL, Redhat and GCC, all to no avail.