SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Enthusiast
    Join Date
    Aug 2005
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Internet Explorer default form-color mystery

    I'm trying to make a form, and it looks fine in Firefox, but in IE the background color for the "Name" input and "Email" input is a tan-sort-of-color. How do I set this back to white? Why is this happening? If I remove any semblance of the word "name" in the XHTML, the form input color reverts back to white. Attached is a picture and code.

    Thanks!



    <div class="clearfix">
    <label for="name">Your Name</label>
    <input type="text" id="name" name="name" size="35" />
    </div>

  2. #2
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Do you have the Google toolbar installed by any chance?

  3. #3
    SitePoint Enthusiast CorkyMcDoogle's Avatar
    Join Date
    Aug 2006
    Location
    Chesapeake, Maryland
    Posts
    77
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What browser are you using?

    It might be some type of auto-fill thing that your browser is doing.

    Does it do that on any other sites?

  4. #4
    CSS & JS/DOM Adept bronze trophy
    Join Date
    Mar 2005
    Location
    USA
    Posts
    5,482
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like you have the Google toolbar installed. Turn off its Autofill feature.

    Edit: lol 3 of us replied to this within 3 minutes of each other.
    We miss you, Dan Schulz.
    Learn CSS. | X/HTML Validator | CSS validator
    Dynamic Site Solutions
    Code for Firefox, Chrome, Safari, & Opera, then add fixes for IE, not vice versa.

  5. #5
    SitePoint Enthusiast
    Join Date
    Aug 2005
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Fixed!

    I adjusted my Google toolbar settings.

    Thanks for the incredibly quick replies.

  6. #6
    SitePoint Wizard silver trophybronze trophy Nadia P's Avatar
    Join Date
    Oct 2004
    Location
    NSW Australia
    Posts
    3,564
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Be aware that if a person viewing the page also has this toolbar, they will see the yellow fill anyways :-) so switching yours off doesn't mean that other's won't see it :-)

    Nadia

  7. #7
    SitePoint Enthusiast
    Join Date
    Aug 2005
    Posts
    36
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Nadia, yes. Thanks. I will keep that in mind.

    Also, does anyone know why the letter "g" is cut off? (It looks like a lower case "q.") This is just for Internet Explorer; it looks fine in Firefox. This only occurs only in form labels.

    Thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •