SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Aaarrrghh Netscape! CSS and <select> problem

    Working on http://www.pitstop1.co.uk/ and losing hair fast (I'm more of a PHP guy than a markup wizard).

    Everything is marvellous in IE 5.x + but Netscape is killing me.

    Netscape 4.x - I'm using a <select> box to navigate but 4.x insists on showing a column of boxes instead of the <select> (I've tried removing / altering practically everything to no avail - have even resorted to using one of those "Site Tune Up" services - nadda). Code is;

    Code:
    <select name="classforsale" class="small" onChange="document.location.href='view.php?search=classforsale&class=' + this.options[selectedIndex].value">
    <OPTION value="all">For Sale
    <OPTION value="all">View All
    <OPTION VALUE="3">Saloon
    <OPTION VALUE="2">Sedan
    <OPTION VALUE="1">Sports
    </select>
    Then for a while I thought Netscape 6.x was my friend and saviour. It produced more or less the same output at IE until this morning, where, in trying to fix the 4.x problem, something I've done has made Netscape 6.x ignore the stylesheet.

    I'm getting to the point here where I'm considering which bridge to jump off so any help is very greatly appreciated.

  2. #2
    SitePoint Wizard Ian Glass's Avatar
    Join Date
    Oct 2001
    Location
    Beyond yonder
    Posts
    2,384
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try putting a size="1" in the select start tag:
    Code:
    <select ... size="1" ...
    ~~Hope This Helps

  3. #3
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Many thanks. Tried it but no luck.

    But you kicked me in the right place. With that, had done just about everything to that select then started wondering if that was where the problem was. Turns out the problem is in the the style sheet;

    Code:
    input, option {
          border-color:purple;  <bug>smileys in code?</bug>
          border-width:1;
          font-family: verdana, helvetica, tahoma, arial;
          font-size: x-small;
          background-color: #FFFFFF;
          color:#ff1177;
    }
    PHew! Now I just got to work out what I did to Netscape 6.

  4. #4
    SitePoint Wizard gold trophysilver trophy
    Join Date
    Nov 2000
    Location
    Switzerland
    Posts
    2,479
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Alright! Finally sorted everything and reversing my opinion about Netscape 6 - it's actually damn good - Netscape seem finally determined to produce a standards compatible browser.

    For anyone having similar problems, the Dev Edge Tupe Up Wizard is one site checker worth looking at.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •