SitePoint Sponsor

User Tag List

Results 1 to 12 of 12
  1. #1
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Unhappy Ugh! Uploaded Wordpress with DW8 and now I have ?PHP/MySQL issue with page address.

    What on earth have I done?

    For example: http:www.mysite.com/contact_us/.htm

    now reads: http://www.mysite.com/contact_us/contact_us/.htm

    I'm not sure if I should have posted this here as this occured only after I uploaded Word Press using Dreamweaver 8. (yes, I had intended to use WP on my host's server. I am freaking out as I can't see how to rectify this as the actual website's files appear normal, in both local and remote view using DW8. I have read that DW may hide the PHP files? I also cannot seem to locate the Remove Connection Scripts Command as suggested in DW8. ( I am going down this route based on my reading of this: "If you've uploaded the MMHTTPDB scripts file to a production server, you should delete the MMHTTPDB scripts file. The Remove Connection Scripts command automatically removes the script files for you." -from the DW help centre) *cry* Am I even barking up the right tree?

    When I navigate through the site, the links still work, but they read as I have shown above. Oddly enough, the index page doesn't have this double up, but just the other pages. HELP! I am pretty sure this is a PHP issue, but I cannot see where or how to remove "whatever it is I need to remove" to correct this issue. I have been on the Adobe site and can see that there have been similiar issues, but I can not understand how to rectify this. Where is the cry emoticon when you need it?

    NB. In case I'm not clear enough, all this drama is on my existing website that is hosted on the server I wanted to set up Word Press on. (Crossed fingers, that this is not clear as mud.)

    Urgent help appreciated.

  2. #2
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm, not sure. The links you show above, were they made from within WP, or are they not part of it? I have a hunch this may have something to do with WP's option to use "pretty url's" (you know, instead of index.php?p=123). I would suggest reverting to the default under Options > Permalinks.
    I think WP also creates a .htaccess file, which you would then have to delete.

  3. #3
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Unfortunately, I didn't get any further than actually uploading WP to my server. Something told me to just have a look at my website to see if all was well after the upload. Sadly, it wasn't and the above was present in the address bar. I have deleted all the WP files I could find using DW. So nothing that I can see on the local site, DW app. or the remote site. I removed them with the DW Site Management option from the DW app and from my remote site. I manually trashed it from my finder too. I agree that WP must have created another file, which I suspect is causing this doubling up of the page address, but I cannot find it. Any suggestions as to where I could look to find the .htacess file? I very much appreciate your help. Thank you. Do post if anything comes to mind.

  4. #4
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I don't use DW so can't help you there. However, a decent ftp-client should allow you to see .htaccess files (that are normally hidden from view). On Mac OS X I use Transmit -- but I suppose you're on Windows, in which case a Google Search can do wonders.

  5. #5
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    No. I am on a MAC. I don't know Transmit. Sadly, Google has only added insult to injury on this occassion.

  6. #6
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I did have Cyber Duck on my old computer. Perhaps I should re-install. Any suggestions on a great free ftp client I can download quickly to have a look now?

  7. #7
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Transmit has a 15 day trial. Otherwise it looks like Cyberduck is the way to go.

  8. #8
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Didn't see your post before downloading CD again. I have had a look around and cant see anything that looks amiss. Any ideas?

  9. #9
    Dinah-Moe Humm mudshark's Avatar
    Join Date
    Dec 2003
    Posts
    1,072
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    So you downloaded Transmit? Under View it has an option "View invisible files" that needs to be ticked in order to see .htaccess files.

  10. #10
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by mudshark View Post
    So you downloaded Transmit? Under View it has an option "View invisible files" that needs to be ticked in order to see .htaccess files.
    Looks like yet another mess up on my behalf. I used Cyberduck. Now to see if Cyberduck has a similiar feature.

  11. #11
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I located Cyberducks show hidden files and selected it...nothing showed up.

  12. #12
    SitePoint Enthusiast
    Join Date
    Dec 2006
    Posts
    94
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay, as I am not sure of all that I don't know that I don't know yet...asking the relevant questions is difficult, but as I am desperate to get this sorted before the Easter holidays I'll keep plugging away. If this is a .htaccess issue, where on my files to I look to correct this? I can't see anything in my root folder ( but then again DW makes these type things invisible right?) and When using Cyberduck, I still can't see anything vaguely resembling .htaccess. Admittedly, I am far from knowing exactly what to look for short of it having the extension .htaccess and sticking out like dog's balls. Talk about frustration station.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •