SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Jan 2002
    Posts
    1
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    New to MYSql please be kind

    hi

    im running win xp pro with apache server 1.3.20, PHP 4.1.1 and MYSQL 3.23.39

    im using them to learn php/mysql so that i can create better sites. so im running localhost.

    i have got apache and php4 running happily (ie when i run a phpinfo() i get the info page) and MYSQL seems to be happy, despite having not wirtten a my.cnf file anywhere!!

    the phpinfo says there is mysql 3.23.39 support but when i try to use mysql in php scripts i get errors
    Warning: MySQL Connection Failed: Can't connect to MySQL server on 'localhost' (10061) in
    and
    Warning: Supplied argument is not a valid MySQL-Link resource in

    any help on how to get it all running nicely together would be much appreciated

  2. #2
    SitePoint Zealot
    Join Date
    Nov 2001
    Location
    Earth
    Posts
    103
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Can you just log directly into mysql? You should be able to open a dos box and execute the msql command line tool (i.e. mysql -u user-id -p). The mysql command line tool should be somewhere in the directories where mysql was installed (sorry, I'm not that familar with the Windows version of mysql).

    Frank
    http://www.serverexpert.com/ Discuss servers and the software that makes them work.
    http://www.webmasters-resources.com/ Resources for webmasters.

  3. #3
    SitePoint Guru
    Join Date
    Aug 2001
    Location
    Amsterdam
    Posts
    788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Are you using apache or IIS???

    Usually (at least at my pc ) there is a program called winmysqladmin.exe (or something simular) and with it you can make a table and see the status of the mysql database!!

    Try to find it...

    Greets,

    Peanuts
    the neigbours (free) WIFI makes it just a little more fun

  4. #4
    SitePoint Enthusiast
    Join Date
    Dec 2001
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    please check once your connecting port no in php.ini filefor mysql .It should be 3306, If you are using the IIS.
    http://www.classicsoftwares.com - Classic Web Development
    http://www.classicresellers.com - Web Hosting for Resellers
    http://www.classicwebhosting.com - Web Hosting Solutions
    http://www.classichostingtool.com - Web Based Tool for Windows

  5. #5
    Mlle. Ledoyen silver trophy seanf's Avatar
    Join Date
    Jan 2001
    Location
    UK
    Posts
    7,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Check your private messages, I did reply

    Sean
    Harry Potter

    -- You lived inside my world so softly
    -- Protected only by the kindness of your nature

  6. #6
    SitePoint Enthusiast Brad's Avatar
    Join Date
    Apr 2001
    Location
    Fresno, Ca.
    Posts
    53
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Make sure that you created the database and assigned a username and password to it. Easiest method is by using the winmysqladmin.exe program.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •