SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Guru Skyblaze's Avatar
    Join Date
    Jul 2005
    Location
    Italy
    Posts
    734
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Problems installing mongrel from book...

    I'm in the final chapter of sitepoint's rails book and i can't install mongrel with instructions in the book....here is the output:

    skyblaze@skyblaze:~$ sudo gem install mongrel --include-dependencies
    Select which gem to install for your platform (i486-linux)
    1. mongrel 1.0.1 (ruby)
    2. mongrel 1.0.1 (mswin32)
    3. mongrel 1.0 (mswin32)
    4. mongrel 1.0 (ruby)
    5. Skip this gem
    6. Cancel installation
    > 1
    Select which gem to install for your platform (i486-linux)
    1. fastthread 1.0 (ruby)
    2. fastthread 0.6.4.1 (ruby)
    3. fastthread 0.6.4.1 (mswin32)
    4. fastthread 0.6.3 (mswin32)
    5. fastthread 0.6.3 (ruby)
    6. Skip this gem
    7. Cancel installation
    > 1
    Building native extensions. This could take a while...
    ERROR: While executing gem ... (Gem::Installer::ExtensionBuildError)
    ERROR: Failed to build gem native extension.

    ruby extconf.rb install mongrel --include-dependencies
    extconf.rb:1:in `require': no such file to load -- mkmf (LoadError)
    from extconf.rb:1


    Gem files will remain installed in /usr/lib/ruby/gems/1.8/gems/fastthread-1.0 for inspection.
    Results logged to /usr/lib/ruby/gems/1.8/gems/fastthread-1.0/ext/fastthread/gem_make.out
    skyblaze@skyblaze:~$

  2. #2
    SitePoint Guru
    Join Date
    Aug 2005
    Posts
    986
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Install mkmf? It should be in the standard library, no?

  3. #3
    SitePoint Guru Skyblaze's Avatar
    Join Date
    Jul 2005
    Location
    Italy
    Posts
    734
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by Fenrir2 View Post
    Install mkmf? It should be in the standard library, no?
    ?

  4. #4
    SitePoint Guru
    Join Date
    Aug 2005
    Posts
    986
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Open irb and type `require 'mkmf'`. Does that work? If it doesn't you have to install mkmf.

  5. #5
    SitePoint Guru Skyblaze's Avatar
    Join Date
    Jul 2005
    Location
    Italy
    Posts
    734
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    irb(main):002:0> require 'mkmf'
    LoadError: no such file to load -- mkmf
    from (irb):2:in `require'
    from (irb):2
    irb(main):003:0> exit
    skyblaze@skyblaze:~$ sudo gem install mkmf
    Password:
    Need to update 13 gems from http://gems.rubyforge.org
    .............
    complete
    ERROR: While executing gem ... (Gem::GemNotFoundException)
    Could not find mkmf (> 0) in any repository
    skyblaze@skyblaze:~$

  6. #6
    SitePoint Guru Skyblaze's Avatar
    Join Date
    Jul 2005
    Location
    Italy
    Posts
    734
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    it's ok....ruby1.8-dev missing


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •