SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Zealot
    Join Date
    Jul 2004
    Location
    england
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    2 column IE5/6 bug

    Hi

    This bug I'm having problem with may have a name and may be featured somewhere else on the site, so if so please do point me in the right direction. However, I can't seem to find anyone else with the same problem!

    I'm trying to create a 2 column layout, one column fixed (for side nav) and one that spans the rest of the width. The height doesn't need to be 100percent, it can be whatever the content needs it to be.

    The bug only appears in IE5 and 6, and after the main content has gone below the side nav content, everything shifts a few pixels to the left...

    I've got an example online here:
    http://www.geturl.co.uk/temp/col.html (you'll need IE 5 or 6 to see the bug though!)

    The CSS is very simple:
    Code:
    #side {
    	width:180px;
    	float:left;
    	background-color:#66FFFF;
    	
    }
    #main {
    	margin-left:180px;
    	border:1px solid #003300;
    }



    Can anyone help me solve this?
    Cheers.

  2. #2
    SitePoint Evangelist
    Join Date
    Jul 2006
    Posts
    493
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Add
    #main ul{height:1%;margin:0;padding-left:30px;}
    to set hasLayout (see FAQ) and let the list-style appear.

  3. #3
    SitePoint Zealot
    Join Date
    Jul 2004
    Location
    england
    Posts
    114
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks for your replies

    I didn't know the bug had a name! But I do now! I've had a read about it in the FAQ thread as well.

    Thanks for your advice - I'll have a good at implementing a solution. Cheers.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •