SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2004
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Cookie problem - works in FF but not IE

    Not sure where to put this, but it's the JS that's causing the problem so I figured maybe should put it here.

    On my site I have two polls. They have separate cookies. Everything was working fine on both FF and IE. Meaning when somebody voted, it checked if there was a cookie for that specific poll, if there was it blocked the vote, if no cookie, it recorded the vote and added a cookie.

    Now, I added a JS popup from internet.com which has a cookie as well (it's a separate page, nothing to do with the two polls). Everything works fine in FF. Each poll checks for it's own cookie and the pop-up checks it's own.

    In IE it won't let people vote at all. I deleted all cookies, files, etc. in IE. But when I try to vote it says already voted.

    I hope that made sense. Anybody know what might be going on?

  2. #2
    SitePoint Wizard
    Join Date
    Mar 2001
    Posts
    3,537
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This line from the script at internet.com:

    window.onload=checkCount;

    could be overwriting another function that was assigned to window.onload in one of your other scripts.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •