Should mysql_real_escape_string work with php ver. 5

Thanks