SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2002
    Posts
    28
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry CSS trouble with links in NS4

    I have 6 links. Three on the left, an image in the middle, and three on the right. In NS4, the three images on the left give me the hand symbol when I mouseover. The three on the right do not. Exact same code, here it is:

    <tr>
    <td width="115" valign="middle" align="left" class="topnav"><a href="http://www.harvard.edu"; class="topnav">harvard home</a></td>

    <td width="135" height="84" align="center" rowspan="3" class="topnav"><img src="test3.gif" border="0" vspace="0" hspace="0" alt="" /></td>

    // THIS LINK DOES NOT WORK !!!
    <td width="125" align="left" valign="middle" class="topnav"><a href="http://www.law.harvard.edu/administration"; class="topnav">administration</a></td>
    </tr>
    <tr>
    <td width="115" class="topnav"><a href="http://www.law.harvard.edu"; class="topnav">hls home</a></td>

    // THIS LINK DOES NOT WORK!!!
    <td width="125" align="left" class="topnav"><a href="http://www.law.harvard.edu/faculty"; class="topnav">faculty</a></td>
    </tr>
    <tr>
    <td width="115" class="topnav"><a href="http://www.law.harvard.edu/students"; class="topnav">students</a></td>

    // THIS LINK DOES NOT WORK !!!
    <td width="125" align="left" class="topnav"><a href="http://www.law.harvard.edu/alumni"; class="topnav">blackboard</a></td>
    </tr>

    Sorry for the mess but this is maddening. Any help and suggestions will be appreciated. Thanks!

    Chris

  2. #2
    Non-Member mmi's Avatar
    Join Date
    Jun 2001
    Location
    Rhode Island
    Posts
    587
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hey Chris - should yer anchor tags have semicolons separating their attributes? - what are the properties of "topnav"?

  3. #3
    SitePoint Wizard
    Join Date
    Oct 2001
    Location
    Tucson, Arizona
    Posts
    1,858
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Originally posted by mmi
    should yer anchor tags have semicolons separating their attributes?
    That's the problem right there. Take those out, and they'll work fine. It's all about the syntax, it's all about the syntax, it's all abou...

  4. #4
    SitePoint Enthusiast
    Join Date
    Jan 2002
    Posts
    28
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    They don't exist...

    those semi-colons are put into the code by this site. They are not in the original code for the page.

  5. #5
    Anyone seen my cypher? OneChance's Avatar
    Join Date
    Apr 2001
    Location
    Seattle
    Posts
    281
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Got a link to the actual page? As mmi asked, what are the properties of topnav?


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •