SitePoint Sponsor

User Tag List

Results 1 to 12 of 12

Thread: help with flash

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Jul 2000
    Location
    boston, ma
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i designed a site in flash (www.dmahesq.com) and certain browsers seem not to be able to view it properly; any hints as to how the code should be (embed/object) - also do i need all that crap at the beginning of the html code which is automatically generated when i export (this file contains......[lots of things seemingly unnecessarily repeated]....?

  2. #2
    SitePoint Enthusiast
    Join Date
    Jun 2000
    Location
    montreal, quebec, canada
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    in regards to the "text used in this movie" tags, i usually delete most if not all of it. it doesn't change the movie, but does increase the size of page to be loaded.
    in regards to browser incompatability, not sure. i'm having my site reviewed at this time, and if i hear of folks having troubles i'll be sure to post it here.

  3. #3
    SitePoint Guru CJ's Avatar
    Join Date
    Apr 2000
    Location
    Mechelen, Belgium, Europe
    Posts
    684
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Maybe the sites which do not display the swf file properly have not installed the Flash4/shockwave plugin. You have to download it somewhere at www.macromedia.com.

    That would be the only reason the flash4 isn't displayed properly actually.

    Christophe


    ------------------
    http://freesources.net - the ultimate webmaster resources site

  4. #4
    SitePoint Member
    Join Date
    Jul 2000
    Location
    boston, ma
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i know what you mean; however, other flash sites are viewed with ease...........any other suggestions - perhaps something to do with "embed" or "object" tags? If so, what?

  5. #5
    SitePoint Enthusiast
    Join Date
    Jun 2000
    Location
    montreal, quebec, canada
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    what version of Flash are you using? and also, what Flash format have you set in your publish settings. I seem to recall that there were "backwards compatibility" problems with Flash.

  6. #6
    SitePoint Guru CJ's Avatar
    Join Date
    Apr 2000
    Location
    Mechelen, Belgium, Europe
    Posts
    684
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Most flash animations are made in the flash4 format. You can see flash3 animations with the flash4 plugin but not the other way around I think.

    Please give us the tag you used to embed (whole line of code) it and the browsers which didn't display the animation correctly.

    Christophe

    ------------------
    http://freesources.net - the ultimate webmaster resources site

  7. #7
    SitePoint Evangelist
    Join Date
    Jun 2000
    Location
    England
    Posts
    587
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

  8. #8
    SitePoint Member
    Join Date
    Jul 2000
    Location
    boston, ma
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you asked for it:<HTML>
    <HEAD>
    <TITLE>DMA&H</TITLE>
    </HEAD>
    <BODY bgcolor="#FFFFFF">
    <table width="100%" cellspacing="2" cellpadding="2" border="2" bordercolor="#000000">
    <tr><!-- Row 1 -->
    <td><!-- URL's used in the movie-->
    <A HREF=clue.html></A> <A HREF=about.html></A> <A HREF=terms.html></A> <A HREF=attys.html></A> <A HREF=qa.html></A> <A HREF=direct.html></A> <!-- text used in the movie-->
    <OBJECT classid="clsid 27CDB6E-AE6D-11cf-96B8-444553540000"
    codebase="http://active.macromedia.com/flash2/cabs/swflash.cab#version=4,0,0,0"
    ID=index WIDTH=550 HEIGHT=400>
    <PARAM NAME=movie VALUE="index.swf"> <PARAM NAME=loop VALUE=false> <PARAM NAME=quality VALUE=high> <PARAM NAME=bgcolor VALUE=#FFFFFF> <EMBED src="index.swf" loop=false quality=high bgcolor=#FFFFFF WIDTH=550 HEIGHT=400 TYPE="application/x-shockwave-flash" PLUGINSPAGE="http://www.macromedia.com/shockwave/download/index.cgi?P1_Prod_Version=ShockwaveFlash"></EMBED>
    </OBJECT></td>
    <td bgcolor="#000000"><a href="mailto:yasmin@dmahesq.com"><img src="kneegrow.jpg" width="360" height="360" alt="" border="0" align=""></a></td>
    </tr>
    </table>

    </BODY>
    </HTML>

    This was what was produced when I exported from Flash- and it seems that if I remove all the repeated "garbage" in the beginning, the page doesn't work properly......help!

    <<< Removed Keywords, Don't do that again! >>>

    [This message has been edited by wluke (edited July 12, 2000).]

  9. #9
    Fluffy Kitten Programmer~ Elledan's Avatar
    Join Date
    Jun 2000
    Location
    Netherlands
    Posts
    1,356
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ouch! Isn't this called spamming?
    If I see this mess, I think that it can be done better, but it will take some time since I haven't worked with Flash for a long time...

    ------------------
    Elledan Dunedain
    Webmaster
    www.emudreams.web.com

  10. #10
    SitePoint Member
    Join Date
    Jul 2000
    Location
    boston, ma
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    what does spamming have to do with this? what do you mean "if" you see it - and why do you refer to my webpage -which you haven't seen- as a "mess"? The page works in many browsers, but not on some macs (which ARE able to see OTHER flash sites)---really i'm wondering if the embed/object tags are "ideal" the way they are --- and i'm also wondering if all that garble at the beginning is necessary....

  11. #11
    SitePoint Enthusiast
    Join Date
    Jun 2000
    Location
    montreal, quebec, canada
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just went through the tedious task of comparing all of your code to the code embedded on my flash pages, (which to my knowledge have received no problem reports), and our code is identical except for that long list of crap. it won't make any difference except in html file size, but you can erase all except "Answers Deitzer Moran & Hallett About Our Firm Our Attorneys HOW To Find Us this month ' s clue LEGAL Terms questions", and if you wish, you can even erase that!
    as i said, other than that, i see no reason whatsoever why your embedding shouldn't work. sorry

  12. #12
    SitePoint Member
    Join Date
    Jul 2000
    Location
    boston, ma
    Posts
    11
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks tiny!- by the way, nice portfolio!


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •