SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict
    Join Date
    Sep 2006
    Posts
    219
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE Css issues on resize and/or hover

    Hi,

    Internet Explorer Issues:

    My Site displays fine on load, but SOMETIMES divs in my site lose their background color when I resize the browser window and my link text SOMETIMES disappears after hovering (I use background images and colors)?

    I can't post the source just yet (behind proxy at work) but could do later if it's neccessary to diagnose the issue, I just thought this may be a well known issue that someone could point out without seeing the source.

    Thanks,

    Dan

    UPDATE:

    Hi, I just saw Pauls response to another post about 'haslayout' and it looks like this is my problem too - I hate IE!
    Last edited by danh2000; Jan 3, 2007 at 22:04. Reason: Update

  2. #2
    American't awestmoreland's Avatar
    Join Date
    Sep 2002
    Location
    Grand Rapids, MI
    Posts
    1,168
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by danh2000 View Post
    I just saw Pauls response to another post about 'haslayout' and it looks like this is my problem too - I hate IE!
    If it was my post you saw the response to, then adding height: 1% to the offending element fixed it for me.

    To make it more "future proof", I used IE conditional comments and an external stylesheet to ensure the style was only applied to IE.
    Example:
    Code:
    <!--[if IE]>
     <link rel="stylesheet" type="text/css" href="css/isaIE.css" />
    <![endif]-->
    Andy
    From the English nation to a US location.

  3. #3
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,556
    Mentioned
    183 Post(s)
    Tagged
    6 Thread(s)
    My Site displays fine on load, but SOMETIMES divs in my site lose their background color when I resize the browser
    Yes, it sounds like the "haslayout" issue as this is a very common occurrence.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •