SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    ScottyTee
    SitePoint Community Guest

    Error occuring since server move...

    Code:
    Parse error: syntax error, unexpected T_STRING, expecting T_OLD_FUNCTION or T_FUNCTION or T_VAR or '}' in /home/7854/domains/---edited----.com/html/includes/class.vc.php on line 18
    I've got a file called class.vc.php. It contains a class which I use to connect to [and query] my database.

    Since moving my websites from a dedicated server to a shared server I have gotten this error when trying to get my site functional again.

    Does anyone have any ideas what could be causing this? Any help is greatly appreciated. Could it be a php4 and php5 problem?

    Cheers,
    Scott

  2. #2
    An average geek earl-grey's Avatar
    Join Date
    Mar 2005
    Location
    Ukraine
    Posts
    1,403
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Don't know how this can be associated with the move from one host to another, but could you post the class code here, please?

  3. #3
    SitePoint Wizard silver trophy
    Join Date
    Mar 2006
    Posts
    6,132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    did you go from php5 to php4? sounds like maybe you did, and your code was written with some syntax that didnt exist until php5.

  4. #4
    ScottyTee
    SitePoint Community Guest
    hi guys, I really appreciate your effort in helping me it was a php4/php5 error. Hadn't realised the site was coded in php5 thats what was causing the error... silly me..


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •