SitePoint Sponsor

User Tag List

Results 1 to 3 of 3

Hybrid View

  1. #1
    SitePoint Member
    Join Date
    Dec 2006
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    NO TEXT LINK SHOWS - absolutely strange!

    I have a text link that's not showing up in FF and Netscape. Yet my page validates. Please go to the url: http://www.bluebonnetsandrain.com/

    and near the top of the page the word "Address" is a link and shows the link hand cursor in IE but in the other browsers you have to move the cursor above and over the apex of the "A" for the link to become active.

    Very Wierd.

    here is the css that goes with the div where this part of the site is:

    #contact{
    position:relative; top:10; left:0; width:570; display:inline; Color:#093; font-size:.85em; white-space:nowrap;
    }
    #contact a:link, #contact a:visited{
    Color:#093; text-decoration:none;
    }
    #contact .phone{
    padding-left:20%; padding-right:20%;
    }
    #contact .address{
    float:right;
    }

    Any help is greatly appreciated.

  2. #2
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Location
    England, UK
    Posts
    34
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi there

    the reason your link isnt working is because you have set z-index values on elements which are covering the address link.

    if you put:

    #contact {
    z-index:5;
    }

    this then works fine in FF

  3. #3
    SitePoint Member
    Join Date
    Dec 2006
    Posts
    6
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    ???!!!

    Well alright!
    Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •