SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict
    Join Date
    Sep 2006
    Posts
    398
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    rollovers not working

    heres my site

    http://www.board-source.com/

    what im trying to do is actually something really simple, i just want a hidden div tag with an image to appear when you roll over the thumbnail, and it works somewhat, but whenver you roll over the bottom ones, the tops ones dont seem to work anymore... can someone help

    EDIT: also in IE, for some reason the new div come up next to the old one instead of over it

    and please, please just dont tell me to validate my site. thanks

    heres the source code

    <table width="100&#37;" border="0">
    <tr>
    <td><a href="http://snow.board-source.com/content/colinspencer.html"><img src="http://snow.board-source.com/images/Images/thumbnail/colinspencer.jpg" alt="" name="latestpic2" width="70" height="70" border="0" style="background-color: #999999" onclick="MM_showHideLayers('mainpic','','hide')" onmouseover="MM_showHideLayers('mainpic2','','show')" /></a> </td>
    </tr>

    <tr>
    <td height="70"><a href="http://snow.board-source.com/content/fsblunt.html"><img src="http://snow.board-source.com/images/Images/thumbnail/fsblunt.jpg" alt="" name="latestpic3" width="70" height="70" border="0" style="background-color: #999999" onmouseover="MM_showHideLayers('mainpic3','','show')"/></a> </td>
    </tr>
    <tr>
    <td><a href="http://www.board-source.com/surf/content/duckdive.html"><img src="http://surf.board-source.com/images/Images/thumbnail/duckdive.jpg" alt="" name="latestpic3" width="70" height="70" border="0" style="background-color: #999999" onmouseover="MM_showHideLayers('mainpic4','','show')" /></a> </td>
    </tr>
    <td><a href="http://skate.board-source.com/content/mikevblanks.html"><img src="http://www.board-source.com/skate/images/Images/thumbnail/mikev.jpg" alt="" name="latestpic3" width="70" height="70" border="0" style="background-color: #999999" onmouseover="MM_showHideLayers('mainpic5','','show')"/></a> </td>
    </tr>
    </table>

  2. #2
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    a) That's not all the code - where are the 'mainpic' divs?

    b) You'll need to post the JavaScript function as well

    c) Validate your code.

  3. #3
    SitePoint Addict
    Join Date
    Sep 2006
    Posts
    398
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    haha, thanks but i got it fixed, i just wasnt hidding the others layers..thanks


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •