SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Thread: Cdo

  1. #1
    SitePoint Zealot
    Join Date
    Mar 2005
    Posts
    166
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Cdo

    Hi,

    I have a pie chart (java applet) on a page that doesn't load when I send it via CreateMHTMLBody "page.asp".
    I already tried to add ", 0" in order to prevent some attachment blocking with no use.

    The rest of the page loads normaly, but the chart.

    Any ideas?

  2. #2
    SitePoint Wizard bbolte's Avatar
    Join Date
    Nov 2001
    Location
    The Central Plains
    Posts
    3,304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    methinks we needs to see some code. what is "CreateMHTMLBody"?

  3. #3
    SitePoint Zealot
    Join Date
    Mar 2005
    Posts
    166
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Oh, sorry

    This is a cdo method used to enbeed external pages whithin the e-mail.

    Which part of code would you like to see?

  4. #4
    SitePoint Wizard bbolte's Avatar
    Join Date
    Nov 2001
    Location
    The Central Plains
    Posts
    3,304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    when you say page doesn't load, what part? the page sending the email or the email itself?

    prolly we need to see the code in question and what errors (if any)...

  5. #5
    SitePoint Zealot
    Join Date
    Mar 2005
    Posts
    166
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    there is no errors.. and the page load perfectly on e-mail. The point is, the pie chart which I can load into the e-mail page normaly in separeted, don't work via CDO.
    I mean, the whole page is sent via e-mail..the one thing is missing is the chart.
    In the meantime I post this firstly, I tested the same script shifting the chart generation to a msoffice component which create a simple chart (excel alike) instead of the java component. The charts loaded normaly this time (the chart in this case is a jpeg instead of vml (generated by java component)).

  6. #6
    SitePoint Wizard bbolte's Avatar
    Join Date
    Nov 2001
    Location
    The Central Plains
    Posts
    3,304
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    most likely, the chart isn't downloading with the email. I would think that it would also trigger some Anti Virus flags as well... How are you referencing the java app in the email? if it's a local path, it won't be found. i haven't ever tried this so i'm not sure exactly how you'd do it...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •