SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Guru Dashman's Avatar
    Join Date
    Jan 2006
    Location
    Manchester, UK
    Posts
    627
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    HELP! - Links not being recognised in IE

    Hi guys,

    I have a very strange problem.
    If you look at this page in IE 6, my links in the main cntent of the page are not being recognised, the normal pointer cursor appears, and the links cannot be clicked.

    I have tried removing the style sheet yet the problem persists.
    This is the section of code where I am currently experiencing the problem.
    HTML Code:
     	<div class="item">
     		<div class="content">
     			<h2><span><a href="/contact" title="title here">Contact</a></span></h2>
     			<p>text here</p>
     
     		</div>
     		<div class="base"></div>
     	</div>
    Any help much appreciated

    Dave

  2. #2
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,476
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Without looking at your source code, it sounds like you have a depth sorting error. Give the links a position of relative, then a z-index that is higher than the rest in that particular block. This will fix IE for you.

  3. #3
    SitePoint Guru Dashman's Avatar
    Join Date
    Jan 2006
    Location
    Manchester, UK
    Posts
    627
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Dan,
    Thanks very much ....

    It seems that I have had to apply the CSS you suggested to every element contained within "item" ..
    The CSS I have used for my "item" divs (as shown in my first post) is as follows:
    HTML Code:
     #main .item{
     	width: 904px;
     	margin: -10px 0 20px 0;
     }
     #main .vitals{
     	display: none;
     }
     #main .item .content{
     	padding: 31px 75px 10px 75px;
     	height: 1%;
     }
     #main .item .base{
     	width: 904px;
     	height: 23px;
     }
    Very weird....

    Thanks again for the help

    Dave


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •