SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict limepickle's Avatar
    Join Date
    Jan 2006
    Location
    Aldridge UK
    Posts
    216
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Missing Submit Button in IE and invalid XHTML

    Heres the page

    I've never come across this before as its the first time I've used XHTML strict.
    The submit button is missing in IE, and also it does not validate, but I cannot see where the problem is by looking at the HTML.

    Hope someone can shed some light on this..

    thanks

  2. #2
    Is Still Alive silver trophybronze trophy RetroNetro's Avatar
    Join Date
    Jul 2003
    Location
    Texas
    Posts
    6,883
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    The validation warning is an extra quote mark in this line
    Code:
    <input name="enews" type="checkbox" id="enews" value="y" " />

  3. #3
    SitePoint Wizard bronze trophy DaveWoods's Avatar
    Join Date
    Dec 2004
    Location
    Derbyshire - UK
    Posts
    2,651
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You main problem is that you have lots of inline elements displayed on your page without placing them inside block level elements.

    You should always place inline elements inside <div>, <p>, <h1> etc wherever appropriate.

    For examle this error

    document type does not allow element "select" here; missing one of "p", "h1", "h2", "h3", "h4", "h5", "h6", "div", "pre", "address", "fieldset", "ins", "del" start-tag.

    Is telling you that "select" is an inline element and it needs to be inside one of the tags it list... probably the most suitable here will be div but in some cases it may be fieldset.

    Hope that helps.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •