SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict
    Join Date
    Jan 2004
    Location
    Nashville
    Posts
    335
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Form Will Not Display with code

    I am trying to call a form on another domain with the following code and the form does not display in IE 7, but it works in FireFox.

    Any ideas?

    ---- start code ----

    $query_string = '';
    $_QS = (count($_POST) > 0) ? $_POST : $_GET;
    $_QS['dT'] = time();
    foreach ($_QS as $key => $value) {
    if(is_array($value)){
    for($i=0;$i<count($value);$i++){
    if( $query_string != '' ) $query_string .= '&';
    if( trim($value[$i]) != '' ) $value[$i] = urlencode($value[$i]);
    $query_string .= $key.'[]='.$value[$i];
    }
    }else{
    if( $query_string != '' ) $query_string .= '&';
    if( trim($value) != '' ) $value = urlencode($value);
    $query_string .= $key.'='.$value;
    }
    }
    foreach ($HTTP_COOKIE_VARS as $key => $value) {
    if(is_array($value)){
    for($i=0;$i<count($value);$i++){
    if( $query_string != '' ) $query_string .= '&';
    if( trim($value[$i]) != '' ) $value[$i] = urlencode($value[$i]);
    $query_string .= "pjx_".$key.'[]='.$value[$i];
    }
    }else{
    if( $query_string != '' ) $query_string .= '&';
    if( trim($value) != '' ) $value = urlencode($value);
    $query_string .= "pjx_".$key."=".$value;
    }
    }
    echo '<link href="http://www.notmy domain.com/pjx_style.css" rel="stylesheet" type="text/css">';
    echo '<script language="JavaScript" src="http://www.notmydomain.com/pjx/pjx-request-info.php?'.$query_string.'"></script>';
    ?>

    -- end code ---

  2. #2
    SitePoint Wizard Pepejeria's Avatar
    Join Date
    Jan 2005
    Location
    Too far up north
    Posts
    1,566
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    What would be more important is the output in the browser, not the PHP code...

  3. #3
    SitePoint Addict
    Join Date
    Jan 2004
    Location
    Nashville
    Posts
    335
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    That's easy....nothing displays.

    ...UPDATE...

    I deleted my cookies and temp internet files and now it works...

    So something was keeping it from working, and I am concerned that others will have the same issue.

    click on the Request More Info button...can anyone not see the form that should display? (please do not fill it out)
    http://www.pilotjourney.com/helicopter-schools (Arkansas Helicopters)

  4. #4
    SitePoint Wizard Pepejeria's Avatar
    Join Date
    Jan 2005
    Location
    Too far up north
    Posts
    1,566
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I see the form in both IE and Firefox...

  5. #5
    SitePoint Addict
    Join Date
    Jan 2004
    Location
    Nashville
    Posts
    335
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Does anyone have an idea what would cause the form not to be displayed?

    On my site 80% of the forms are called via the above code - but those forms only account for 10% of the results.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •