SitePoint Sponsor

User Tag List

Results 1 to 10 of 10
  1. #1
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Smile is that php can do with this

    in my site some liks are start with https when user comes on this pages using IE then i get follwoing message

    "This page contains both secure and nonsecure items. Do you want to display the nonsecure items?"

    how can i remove this message.

    thanks

  2. #2
    SitePoint Guru MikeBigg's Avatar
    Join Date
    Jun 2004
    Location
    Reading, UK
    Posts
    970
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    This may be the images (or other objects) on your site coming from http:// not https://, hence the secure and non secure message.

    The images should come from https:// too.

    Mike

  3. #3
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    just by changing the paths to https while calling images, scripts etc will do the purpose ?

  4. #4
    SitePoint Wizard silver trophy
    Join Date
    Mar 2006
    Posts
    6,132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    you probably need to do it for all external objects. this may include any urls in css or js files etc... as well.

  5. #5
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    oh great
    thanks

  6. #6
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    after doing somw how still the problem is their so i tried this

    In Internet Explorer, click the Tools button, and then click Internet Options.
    Click the Security tab.
    Click the Internet icon.
    Do one of the following:
    To pick a preset security level, drag the slider.
    To change individual security settings, click Custom level. Change the settings as desired and click OK when you are done.
    To set Internet Explorer back to the default security level, click Default level.
    When you are finished making changes, click OK to return to Internet Explorer

    and it is resolved is this is the correct method ?

  7. #7
    SitePoint Addict richtestani's Avatar
    Join Date
    Nov 2003
    Location
    Bridgeport
    Posts
    292
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You could simply allow your https to work across the whole site which should remove that message.
    RichTestani
    -------------------------------
    http://www.junkdepot.com
    http://www.rareoopdvds.com | The Movie Poster Site

  8. #8
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    is this is the correct method ?

  9. #9
    SitePoint Wizard silver trophy
    Join Date
    Mar 2006
    Posts
    6,132
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    simplecode, do you really think that your visitors are going to change thier security settings just for you? i would leave your site immediately if i saw instructions to change my security settings. in fact, i thnk a good amount of users would run after seeing the first warning from IE.

    just fix the problem.

    if you are sure you changed all your absolute urls, then maybe you should clear your browser cache and try again.

  10. #10
    SitePoint Wizard simplecode's Avatar
    Join Date
    Jun 2006
    Posts
    1,129
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yes you were right and am trying to fix it

    in view source

    <!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN"
    "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd"><html>

    this is on the header part

    then all links are like //images/spacer.gif

    and all hrefs are like <a href="http://mysite">home</a>

    thats all from view source

    when i search in this files view source i found only these entries for http


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •