SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Member
    Join Date
    Nov 2006
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    entering html in textedit

    I am working through book BUILD YOUR WEBSITE THE RIGHT WAY.
    When I enter html code into textedit the first word is underlined is a broken red line.
    Does anyone know what that means, why it happens, how can I stop it happening, and does it matter?

    musician1

  2. #2
    .* draziW tnioPetiS *. bronze trophy
    Join Date
    Jun 2004
    Location
    "Then I figure the most good good guy will win."
    Posts
    1,666
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Sounds like spell check... It thinks your word/code is misspelled... I am not on a Mac at the moment, but first thing I would do is convert the doc to "plain text".... that is somewhere under options/prefs... Not sure if you can turn-off spell check though...

    If it is the spell chekc, then it is safe to ignore.

  3. #3
    CTO htmlguy's Avatar
    Join Date
    Feb 2005
    Location
    North Carolina
    Posts
    420
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    As mhulse said, this is spellcheck. I'm not sure how to turn it off, but it will show that almost all of your lines are incorrect if they have <> around the words. The best thing you can do is get yourself a real editor (you can get free ones, just use google) or figure out how to turn off the spellcheck.
    HTMLGuy

  4. #4
    Brevity is greatly overrated brandaggio's Avatar
    Join Date
    Dec 2005
    Posts
    1,424
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by musician1
    I am working through book BUILD YOUR WEBSITE THE RIGHT WAY.
    When I enter html code into textedit the first word is underlined is a broken red line.
    Does anyone know what that means, why it happens, how can I stop it happening, and does it matter?
    Assuming you are talking about TextEdit.app for Mac, you will need to turn the editor setting from rich text to plain so that you can code properly. By default it creates docs in RTF.

    To switch to plain text go to:
    Preferences>New Document>Radio Button for Plain Text

    In this same tab you can uncheck "Check spelling as you type".

    Please also note you can alter the character encoding and doctype under the Open and Save tab.

    Although TextEdit is not a bad app at all (and comes bundled with Macs), two better, free alternatives for text editors are
    Smultron and TextWrangler.

    I use TextEdit when I need to create an RTF doc (like a Word doc), but prefer the more code focused text editors mentioned above when coding.

  5. #5
    SitePoint Member
    Join Date
    Nov 2006
    Posts
    10
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    spelcheck in textedit

    Thank you John Wozniak

    That was exactly what I needed to know
    thanks
    musician1


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •