SitePoint Sponsor

User Tag List

Results 1 to 7 of 7
  1. #1
    SitePoint Wizard
    Join Date
    Jan 2005
    Location
    blahblahblah
    Posts
    1,447
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    When can I start using the Zend Framework?

    Is it safe now? What bad could happen if I start working on an application with it?


  2. #2
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    It could update...thats the only thing you have to worry about is keeping up to date.
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  3. #3
    SitePoint Evangelist
    Join Date
    Mar 2003
    Location
    Melbourne, Australia
    Posts
    463
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    yep, i've been testing with it
    and when they went from 0.15 to 0.2 i only had one issue with Zend_Config
    which was easily fixed
    not that i'm using a huge amount of the framework

    but, anything that's in the library (not incubator) should be ok to use
    but don't expect all code to work from update to update, especially while they're still only in preview releases

    hth
    dave

  4. #4
    SitePoint Guru
    Join Date
    May 2003
    Location
    virginia
    Posts
    988
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thinking about using mainly the MVC components myself. Simple paypal site. Using Doctrine and a couple of my own classes.

    Asking for advice... should I or no?

  5. #5
    SitePoint Member
    Join Date
    Nov 2006
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I already migrated some sites to Zend Framework... Works fine now...

    Was needed some manual fixing of 2-3 lines but otherwise works fine for me now...

  6. #6
    SitePoint Wizard
    Join Date
    Jan 2001
    Location
    Grand Rapids, MI
    Posts
    1,284
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    The framework is at 0.7.0, with just about all components being stable, I don't see why now would be a problem. As long as you keep update to date on any changes, it should be fine.

  7. #7
    SitePoint Member
    Join Date
    Nov 2006
    Posts
    24
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Is safe to develop but personally i am wondering if is so safe for me now to replace on existing sites Zend Framework 0.6 with Zend Framework 0.7

    There are some sites with over 100.000 page views/day, if something is not compatible...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •