SitePoint Sponsor

User Tag List

Results 1 to 7 of 7

Thread: embed a video

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    embed a video

    I'm having trouble trying to embed a video into my site. Mostly because I don't know what some of the code means, and if it needs to be there or not. I'm trying to learn this from another person and I feel like he's giving out too much coding and that I don't need some of it...to add to that he just says "this goes here" without saying why it goes there or what it's for so I'm left puzzled.

    Frustrating not knowing what your doing but I don't want to quit.

    this is the code he showed me, but I can't use this I have to come up with my own.

    <body class="audio">
    <div>
    <object classid="CLSID:22D6F312-B0F6-11D0-94AB-0080C74C7E95" type="video/x-msvideo" width="640" height="480" title="Victor Navone, c 1999">
    <param name="src" value="aliensong.mpeg" />

    <script type="text/javascript">
    // <![CDATA[
    if (navigator.mimeTypes && navigator.mimeTypes["video/mpeg"])
    {
    document.write('<embed src="aliensong.mpeg" bgcolor=#000000" width="640" height="480" type="video/mpeg"></embed>');
    }
    else
    {
    document.write('<b>Error/b>: Sorry, Plugin required.');
    }
    // ]]>
    </script>

    </object>
    </div>

    all the things in bold are basicaly what I don't get...oh and get this, all the commands he explained to me....pretty much 80% of them aren't in this coding so thats a big help. I'm glad I'm going to school to learn basicaly nothing from this guy. And this is due tomorrow at midnight...all I have to do is put a video on a site, nothing fancy...but this guy seems to make it complicated, or maybe it's just me.

  2. #2
    . shoooo... silver trophy logic_earth's Avatar
    Join Date
    Oct 2005
    Location
    CA
    Posts
    9,013
    Mentioned
    8 Post(s)
    Tagged
    0 Thread(s)
    Logic without the fatal effects.
    All code snippets are licensed under WTFPL.


  3. #3
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    where do you get the classid...?

  4. #4
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Ok I got the video to show up. Next thing I need is, and this is MUST...the control panel has to disapear and the video has to start on it's own. This is my coding...

    <object type="application/x-shockwave-flash"
    data="http://www.youtube.com/v/o1u-XtTql1c"
    width="425" height="350">
    <param name="src"
    value="http://www.youtube.com/v/o1u-XtTql1c" />
    <param name="autoplay" value="false" />
    <param name="controlpanel" value="true" />
    </object>

    I can switch the autoplay and panel options all I want the video is gonna appear the same anyways...I don't know any other way to make it auto start without the panel....something in CSS?

    This is a youtube video btw...

  5. #5
    Brevity is greatly overrated brandaggio's Avatar
    Join Date
    Dec 2005
    Posts
    1,424
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You can apparently autostart the video like so.

    If these are your videos you can create your own player in Flash or embed MOV or WMV and have more/some control over the controls that are available.

    This is the place to go for great code examples for using a variety of types of multimedia/movies in your page/s should you need them.

  6. #6
    SitePoint Enthusiast
    Join Date
    Nov 2006
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Got er done! Thanks guys. Just got 1 little problem validating my CSS...after that I'm done.

    .footer
    {
    background-color:#000000;
    position:absolute;
    top:500px;
    left:112px;
    width:800px;
    height:100px;
    }

    It says: Line : 43 (Level : 1) You have no color with your background-color : .footer

    I tried googling this one but you guys on this forum give me straight forward info, that's all I need.

  7. #7
    Brevity is greatly overrated brandaggio's Avatar
    Join Date
    Dec 2005
    Posts
    1,424
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by JoeForts
    Got er done! Thanks guys. Just got 1 little problem validating my CSS...after that I'm done.

    .footer
    {
    background-color:#000000;
    position:absolute;
    top:500px;
    left:112px;
    width:800px;
    height:100px;
    }

    It says: Line : 43 (Level : 1) You have no color with your background-color : .footer

    I tried googling this one but you guys on this forum give me straight forward info, that's all I need.
    It's a warning not an error. You can make it go away by placing a color on your footer for text or if you don't require it you can leave it as is.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •