SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Zealot
    Join Date
    Oct 2002
    0 Post(s)
    0 Thread(s)

    775 file upload worked before... not now?

    We have an image upload script. On our previous server, our image directories were 755 and it uploaded fine. We moved to a new dedicated server and the script stopped working. It got a permission denied error. We changed the chmod to 777 and then it worked. Why would this be? I feel weird having important image folders 777. Is this bad?

    thanks in advance for your advice.

  2. #2
    SitePoint Wizard cmuench's Avatar
    Join Date
    Jul 2005
    At my computer
    0 Post(s)
    0 Thread(s)
    The problem is PHPSuexec
    Your old server had it thats why you had to make the folder 755.
    The new server doesn't so that why you had to make it 777. You could always make a new folder to store the stuff or make the folder outside of your web html directory. So say for instance Your linux path is
    create a new folder in /home/guy names images and then people can't see what you are uploading to it because you can't reach that folder from the web. then when you go to link to it just put /home/guy/images/filename


Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts