SitePoint Sponsor

User Tag List

Results 1 to 11 of 11
  1. #1
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    viewing web pages on iis5 from another account.

    I'm working with windows 2000 professional.
    I understand that it is advisable to install and set things up on the system from within the administrator account and to work on a day to day basis as a regular logged on user.

    So how do I upload to and request from iis web pages from a non administrator login?

    I http://localhost and that didn't work.

  2. #2
    Xbox why have you forsaken me? moospot's Avatar
    Join Date
    Feb 2001
    Location
    Clearwater, FL
    Posts
    3,615
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Could you describe your problem a bit more? Are you trying to upload and retrieve with FTP? Did you set up a web? Did you set up a virtual directory? Did you check your permissions?

    You should tell us all the steps you have taken to this point and describe the exact problem in more detail. Then we should be able to help more.

  3. #3
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    here's the background

    I really know nothing about how to manage a server. In the past, to test asp scripts on my own computer I would log onto windows 2k as administrator. Uploading files to the server is just saving them on the inetpub/webroot directory. Calling them to a browser was just typing http://localhost/website/file.asp into the address bar.

    Now, I want to work on the same computer, but logged on as a regular user.

    So I need to know how to do that. Really basic explanation from step one.

  4. #4
    Xbox why have you forsaken me? moospot's Avatar
    Join Date
    Feb 2001
    Location
    Clearwater, FL
    Posts
    3,615
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You should just be able to save your files in the folder you want (i.e. c:\inetpub\wwwroot\yourwebsite).

    Are you getting an error when you try to save the file?

    You should also be able to view the pages as a local user as well. If you type in that address in IE, what happens?

    Any errors there or just no page?

  5. #5
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Right now I'm logged on as administrator since I've been busy dowloading and installing stuff (just now put on opera 6). Tommorrow morning I'll log on both ways and let you know for sure. But I think that when logged on as a regular the iis directories do not appear in windows explorer.

    I'll report the details better tommorow, that is, in about 7, 8 hours.

    See ya.

  6. #6
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    here's more details

    What I did was to create a directory under inetpub/wwwroot called testsite. Then, I saved a file, default.html to that directory.

    Then I logged in with a regular user account ("power users" grouping as defined in w2k) and typed localhost/testsite/default.html and got a prompt to give user name and password. I logged in as administrator and got to see the page.

    Then, when I tried to save a file to the testsite directory (I was able to find it in windows explorer) I was denied access and not given the prompt to give username and password like I was when I called the file with an http request.

    So I went back and logged in as administrator, right clicked the testsite folder and shared the folder with my regular user account. In the share I gave full control.

    Then I went back to my user account and was still unable to save a file to that directory.

    In addition, now, even when logged on as administrator, I am prompted for user name and password before getting to view pages on the wwwroot directory.

    I would like to know the best way to work on a website hosted on iis from my regular user account. I just need be able to make directories and save files under inetpub/wwwroot and to request them for viewing in a browser.

  7. #7
    Xbox why have you forsaken me? moospot's Avatar
    Join Date
    Feb 2001
    Location
    Clearwater, FL
    Posts
    3,615
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Now that is an excellent description of the problem.

    There are a couple of things you can try...

    1) http://support.microsoft.com/default...;EN-US;Q238923
    To correct this problem, use http://Localhost to connect to the site or change the settings in Internet Explorer by performing the following steps:

    Open Internet Explorer 5.0 and click Tools .

    On the Tools menu, click Internet Options .

    In the Internet Options window, click on the Security .

    In the list, click Local Intranet , and then click Sites .

    In the Local Intranet window, click Advanced .

    In the Add This Web Site To This Zone box, add "http://127.0.0.1" and click Add .

    Click OK .

    Click OK , and then click OK again (to get back to the browser).


    Restart Internet Explorer and try to browse the site again.
    2)http://support.microsoft.com/default...;EN-US;Q229781

    This basically says that you need to set the appropriate share level permissions. That means set the testsite folder permissions to readonly for IUSER

    I'm a bit rusty with IIS, so I am reinstalling it on my computer. I will post a walkthrough on getting a website up and running.

    In the meantime, try those two options first. There are some other things we cna look at, but I want to get you started on something.

  8. #8
    Xbox why have you forsaken me? moospot's Avatar
    Join Date
    Feb 2001
    Location
    Clearwater, FL
    Posts
    3,615
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Okay then, here we go..from scratch...

    Setting Up a New Web on IIS 5.0 (Win2k)

    1. Create the folder where you want your new web. This is usually c:\inetpub\wwwroot\mywebsite.

    2. Click Start , point to Programs , select Administrative Tools , and then click Internet Services Manager.

    3. In the left pane, right-click Default Web Site, point to New, and then click Virtual Directory.

    4. In the first screen of the Virtual Directory Creation Wizard, type a name for the site (such as mywebsite) and click Next.

    5. In the second screen, click Browse. Browse to the content folder that you created in section 2 (in this example, it is c:\inetpub\wwwroot\mywebsite). Click Next.

    6. In the third screen, select Read and Run scripts (such as ASP). Make sure that the other check boxes are cleared. Click Finish to complete the wizard.

    7. Right-click the new virtual folder and click Properties.

    8. Click Virtual Directory and make sure that the Web site name is listed in the Application Name edit box under Application Settings . If it is not, click Create .

    9. Close the Properties dialog box and close IIS.
    Last edited by moospot; Dec 21, 2001 at 09:20.

  9. #9
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    that worked. But.....

    That did the trick. Thanks.

    I just thought that the subdirectories of wwwroot are automatically websites who's pages respond to http requests. I didn't realise that you had to link them to virtual directories.

    Do the files have to be under the inetpub/wwwroot directory?

    Two issues remain.
    1)
    I still have to authenticate with administrator password to see the files in the inetpub root directory. But I guess I can live with that. I suppose thats because I didn't link it with a virtual directory.

    2)
    netscape 4.5 cant seem to submit a form to an asp page. Opera 6 and ie5.5 managed fine

    <form action='' method='post'>
    <input name='name' value=''>
    <input type=submit name='submit1' >
    </form>

    The page itself does get found by the browser and the above form is loaded. But when netscape submits the form, instdead of geting the response generated by the script, located on the same file, it displays: "This page cannot be displayed because the page address is incorrect." And the name of the file containing the script no longer displays in the address bar. (I guess that's because the browser thinks it couldn't be found. But its the same page that contains the form!)

    What gives?



    Andy

  10. #10
    Xbox why have you forsaken me? moospot's Avatar
    Join Date
    Feb 2001
    Location
    Clearwater, FL
    Posts
    3,615
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Try puttting in the page name in your form tag...and use double quotes on everything in your tags. Netscape is a bit strict when it comes to things like that.

    IE and Opera will even let missing table tags go and still display the page.

    Code:
    <form action="yourpage.asp" method="get"> 
    <input name="name" value=""> 
    <input type="submit" name="submit1"> 
    </form>
    Use the GET method for troubleshooting your form as well. It will display all your values in the QueryString. (i.e. http://localhost/yourpage.asp?name=y...submit=submit1 should dhow up in the address bar after you submit your form)

  11. #11
    SitePoint Zealot akohl's Avatar
    Join Date
    May 2001
    Location
    Israel
    Posts
    184
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    quote marks, ect

    actually, I did use double quotes everywhere in the tags. Its just that I forgot to use the encodement for those characters so it got all messed up on this web page.

    I will try writing the name in the action attribute. It actually makes sense that that could make a difference.
    I'll let you know later.

    Thanks.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •