SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Member
    Join Date
    Oct 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    DotNetNuke - Newsletters not sending images in email

    Hi,

    I have installed DotNetNuke 4.0 and I tried the to send some bulk mail from the Newsletter (Admin -> Newsletters). The email message consisted of both text and images. I have noticed that the emails that are received display only the text but not the images.

    Can someone please guide me how to fix this problem... any help will be much appreciated.

    Thanks.

    Karan

  2. #2
    ALT.NET - because we need it silver trophybronze trophy dhtmlgod's Avatar
    Join Date
    Jul 2001
    Location
    Scotland
    Posts
    4,836
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I've never dealt with DotNetNuke so I might not be of much use. Where are the images stored? Make sure their in the correct place and linked to properly. It might also be a setting in your email client.

  3. #3
    SitePoint Member
    Join Date
    Oct 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well... for testing I just inserted images from the root directory where all the images are stored. I didnt try any fancy stuff. I also check the html code for the images and they looked alright. Its only when I receve the email in my inbox is when the images dont seem to open. I checked with different email addresses - hotmail, gmail, outlook express but the same.

    Please help.

  4. #4
    SitePoint Mentor NightStalker-DNS's Avatar
    Join Date
    Jul 2004
    Location
    Cape Town, South Africa
    Posts
    2,873
    Mentioned
    45 Post(s)
    Tagged
    0 Thread(s)
    So the link to the image is a full url? eg: "http://www.domain.com/image1.jpg"

    Is it not maybe being blocked by the email client? Coz I know outlook and gmail block images unless the domain is set as safe. Then it displays the images. Not sure about hotmail tho.

  5. #5
    SitePoint Author silver trophybronze trophy
    wwb_99's Avatar
    Join Date
    May 2003
    Location
    Washington, DC
    Posts
    10,625
    Mentioned
    4 Post(s)
    Tagged
    0 Thread(s)
    You need to look at the source of the delivered message to see what DNN's emailer did to them.

    Also, some of those mail hosts block outside images. Did you see any placeholders?

  6. #6
    SitePoint Member
    Join Date
    Oct 2006
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Yes, thanks. I will check if my host doesnt allow emails to be sent. I can actually see the border and alternate text of the images in the email but the images dont load. I will check a few things again.

    Thanks for the help guys..


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •