SitePoint Sponsor

User Tag List

Results 1 to 8 of 8

Thread: Main Nav Block

  1. #1
    SitePoint Addict SunnaH's Avatar
    Join Date
    Aug 2005
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Question Main Nav Block

    I think I am looking at my code too long. I just need to know a small issue. The last item on my main nav "Sponsorship" vanishes when the browser window is reduces less than 800. I know I need to add an attribute to my CSS but not sure. I just do not want it to vanish away. Thanks.

    http://www.stc.org/54thConf/

    -=SunnaH=-

  2. #2
    In memoriam gold trophysilver trophybronze trophy Dan Schulz's Avatar
    Join Date
    May 2006
    Location
    Aurora, Illinois
    Posts
    15,478
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Everything looks fine on my end. I'm using Opera 9 on Windows XP Pro with Service Pack 2.

  3. #3
    SitePoint Addict SunnaH's Avatar
    Join Date
    Aug 2005
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Let me clarify:

    -Make the window 800 by 600
    -Then reduce the window so the main navigation would go out of the viewing area
    - do not do it fast or you will not see what i am talking about
    -once the viewing are just reaches the vericle line after "Sponsorship" you will see it

    You will notice that the last item on the menu "Sponsorship" will disappear. It should be locked in place and just go out of the viewing area.

  4. #4
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I only had a look in FF, but removing display: inline from #p7TBMroot li brought the last link back. Not sure how that'll go in IE though.

  5. #5
    SitePoint Addict SunnaH's Avatar
    Join Date
    Aug 2005
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Tyssen you are right. That worked in FF and Opera but it broke it in IE. So there must be an additional fix? IE is also wrapping the nav.

  6. #6
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    About the best I can come up with is this:

    Code:
    #p7TBMroot li {
    	list-style-type: none;
    	font-size: 0.875em;
    	text-align: left;
    }
    
    * html #p7TBMroot li {
    	display: inline;
    }
    As you say, IE wraps the nav so you may need to create more space below the nav for the submenus to appear at the smaller window size.

  7. #7
    SitePoint Addict SunnaH's Avatar
    Join Date
    Aug 2005
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, Ill keep working on it. I appreciate you look at it.

  8. #8
    SitePoint Addict SunnaH's Avatar
    Join Date
    Aug 2005
    Posts
    263
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Angry

    I am getting really frustrated.I just cannot figure out the problem why my main nav is wrapping in IE. Can anyone help me out please?

    http://www.stc.org/54thConf/

    -=SunnaH=-


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •