It seems to be that most hosting service providers still tend to keep PHP 4 on their servers. Are they led by backward compatibility concerns, it doesn't matter really. But it's a real headache for a developer when he/she is forced to develop on PHP 4 while the fifth version would bring the application to a whole new level (in the developers point of view).

But it also seems to be that more and more hosting service start providing PHP 5 as well. So now my concern is which would I choose as a developer? If I was going to develop a product, would I choose PHP 4 because it's used on majority of servers, or PHP 5 which is coming inevitably but may cause a loss of potential clients who still use PHP 4?

What are your thoughts about it? What would you choose?