SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Enthusiast
    Join Date
    Sep 2006
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Help! AlphaImageLoader in IE 6

    Hey everyone,

    I'm trying to use the AlphaImageLoader filter in IE to use PNGs with alpha transparency as the background for a div.

    Here's the URL:
    http://www.blueleafphotography.com/pngTest.html

    Here's the HTML:
    HTML Code:
        <div class="floatLeft" style="background-image: url(logo.png); height: 108px; width: 121px;"></div>
        <div class="floatLeft" style="filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(enabled='true', src='logo.png', sizingMethod='image'); height: 108px; width: 121px;"></div>
        <div class="floatLeft" style="filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(enabled='true', src='logo.png', sizingMethod='crop'); height: 108px; width: 121px;"></div>
        <div class="floatLeft" style="filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(enabled='true', src='logo.png', sizingMethod='scale'); height: 108px; width: 121px;"></div>
        <div class="floatLeft" style="background-image: url(logo.png); _background-image: none; _filter: progid:DXImageTransform.Microsoft.AlphaImageLoader(enabled='true', src='logo.png'); height: 108px; width: 121px;"></div>
    Any ideas what I'm doing wrong? divs 3, 4, and 5 work fine in IE 5.5 but none of them work in IE 6.
    Last edited by MaverickDesign; Oct 4, 2006 at 15:08.

  2. #2
    I meant that to happen silver trophybronze trophy Raffles's Avatar
    Join Date
    Sep 2005
    Location
    Tanzania
    Posts
    4,662
    Mentioned
    2 Post(s)
    Tagged
    0 Thread(s)
    I don't know what you're doing wrong, but perhaps you'd be better off using premade scripts that deal with this, like this one: http://homepage.ntlworld.com/bobosola/

  3. #3
    SitePoint Enthusiast
    Join Date
    Sep 2006
    Posts
    59
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, I tried that script and had the same problem. It displays okay in IE 5.5 but not in IE 6. I'm exporting everything as PNG 32, could that be the issue? Microsoft doesn't have much for information on the filter.

  4. #4
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can see all five logos in IE6 with the last four showing correct transparency.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •