SitePoint Sponsor

User Tag List

Results 1 to 6 of 6
  1. #1
    SitePoint Addict
    Join Date
    Mar 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CF appl works in IE not in Firefox..was working in FF before

    This is the most craziest thing I have seen. I had small application wherein user logs in and accesses the site. It was working fine with user taken to home page if login succeeds and things like that. Now when I try in FF, I can see is user is authenticated etc by looking at APPLICATION , CLIENT VARs (that I set) in Debugging pane but the page doesnt move from Login.cfm to Home.cfm even though the url suggests you are on Home.cfm. The same username pwd works fine in IE and I am able to browse other pages in the site.

    Anyone knows whats wrong??? by the way, the in Debugging pane right at the bottom after URL PARS, i get 500 null which is strange,

    [B] URL Parameters:
    CFID=1112
    CFTOKEN=2222222

    Debug Rendering Time: 63 ms

    500 null[
    /B]

    Thanks in advance...

  2. #2
    SitePoint Wizard aaron.martone's Avatar
    Join Date
    Feb 2003
    Location
    Florida, USA
    Posts
    2,322
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Are you using Windows Integrated Authentication to capture username/password? If so, by default, Firefox does not support this proprietary form of user authentication, however you can read up here for ways of making Firefox work with WIA.

    http://ackbarr.xoops.org/archives/20...on-in-firefox/

  3. #3
    SitePoint Addict
    Join Date
    Mar 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hi,
    I understand what you are trying to say... but how come the site was working before??? I didnt do any changes... My system crashed and I had to reboot and next thing I know, the login page wont work even though it works fine in IE... Any more suggestions or did I miss something here??

    Does it have to do anything with CF Admin ???

    Thanks again..

  4. #4
    SitePoint Guru
    Join Date
    Jul 2005
    Posts
    609
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Firefox will popup and ask for your username and password if WIA is turned on. If you think WIA might be the cause (I'm don't think that it is), then turn off WIA in a test folder and try again. You get 500 NULL only in FF though? That's odd. What crashed? Does this happen on all FF browsers, or have you just tried one?

    Aaron, that's a GREAT post, thanks! That'll come in wicked useful on my Intranet.

  5. #5
    SitePoint Addict
    Join Date
    Mar 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    There seems to be confusion. What I am saying is after I enter login info on Login.cfm and press submit button, I am kept at same page i.e same Login.cfm is shown, even though the URL is changed automatically to HOME.CFM?CFID=1370&CFTOKEN=57003128.... The 500 NULL is shown right at the bottom of debuggin screen and is not part of the ACTUAL PAGE.. I hope its clear now....

    by the way I have field which gets set if login was successful.. I checked that field i.e success date and the value changes if I login & logout and login again which means the login part works fine.... As I said It was working fine earlier, and works even now in IE ... Only thing i have done recently is installed NO SCRIPT extension of FF.. but today I tried to Login by disabling NO SCRIPT and restarting browser again but same thing happens... cant get beyond Login page...

    Thanks ..

  6. #6
    SitePoint Addict
    Join Date
    Mar 2006
    Posts
    200
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    OK , i have fixed the problem...........woohooo.... All I did was noticed how cfid & cftoken were changing in IE when I logged in, but it was not happening with FF. Went to FF options, removed the coookies cfid & cftoken and vola, I am able to login again... thanks everyone...

    anyone seen this before???


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •