SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Jan 2006
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    IE links don't work with png transparency

    Hey,

    I have a site witha drop shadowed png for the bg - it works fine for firefox, but when I add the transparency hack (ie ^) half of the links stop working:

    /* filterrogidXImageTransform.Microsoft.AlphaImageLoader(enabled=true, src='/webfiles/images/mainBG.png',sizingMethod=scale);*/

    When I comment it out, it works fine.

    Anyone see this before?

  2. #2
    .* draziW tnioPetiS *. bronze trophy
    Join Date
    Jun 2004
    Location
    "Then I figure the most good good guy will win."
    Posts
    1,666
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Seen it... here is a test page one of the folks (Ingo Chao) on the css-d mailing list put up. Maybe it will help.

    I typically try to avoid using links and png filters together.... basically the filter puts the image on top of the link.... From my tests, if you have transparent spots in your image, then your link will be clickable only in those areas. I have not tried z-index and position: relative (like above example) but that may work.

  3. #3
    SitePoint Enthusiast
    Join Date
    Jan 2006
    Posts
    54
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, taht helped. I should have deduced it.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •