SitePoint Sponsor

User Tag List

Results 1 to 6 of 6

Hybrid View

  1. #1
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Buffalo, NY
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Display issue in pop-up window

    I'm not sure which forum to post this inquiry in...

    I have pages in my dynamic content portion of the site (which I am hoping to launch within the next couple weeks to replace static content pages) that display image thumbnails. Clicking on the thumbnail opens a new window that displays the full sized image, along with descriptive text and two navigational arrows that allow you to cycle through the other images in the current group.

    Sometimes, when you open the full sized image window, or use one of the navigational controls to view the next image, only the top half of the descriptive text shows up. Refreshing the page, or navigating back to the previous image corrects the display issue, but the issue keeps coming back. Oh, and this problem only seems to come up in internet explorer.

    Here's the URL for one of the "thumbnail" pages:

    http://www.markdivincenzo.com/newpai...?period=recent

    Does anyone have any suggestions on how to correct this ? Should i post this inquiry to a different forum ?

    Thanks

  2. #2
    Object Not Found junjun's Avatar
    Join Date
    Mar 2002
    Location
    northern MI
    Posts
    1,392
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I can't help you specifically on your problem, only tell you the solution I used for the exact same scenario; ThickBox.

    Works like a charm and fullfills your criteria for image caption and navigation forward/backwards.
    http://jquery.com/demo/thickbox/

  3. #3
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Buffalo, NY
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, I'll give this a shot. I won't be able to try it until later in the week since it's more than a couple quick steps. I'll post back to let you know if it worked after I have tested it.

  4. #4
    Guru Meditation Error gnarly's Avatar
    Join Date
    Dec 2003
    Location
    Cheltenham, United Kingdom
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    It sounds like either the peekaboo or guillotine bugs to me.

    To fix it, you usually have to give the parent element "layout". It's an IE-specific property - more at http://www.satzansatz.de/cssd/onhavinglayout.html

    Adding #wrapper { zoom: 1; } to your CSS might well do the trick.
    Olly Hodgson
    thinkdrastic.net

  5. #5
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Buffalo, NY
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Thanks, i'll try adding #wrapper {zoom:1;} and see what that does.

  6. #6
    SitePoint Enthusiast
    Join Date
    Sep 2005
    Location
    Buffalo, NY
    Posts
    40
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    adding #wrapper {zoom:1;} seems to have fixed it. thanks !


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •