SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Addict Tizer's Avatar
    Join Date
    May 2002
    Location
    Beach
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Something (like a transparent div) blocking links (ie) - but I can't see it :(

    Hi

    If you go to this page using ie 6 you can see some links I have made in the text - but it is impossible to click them!

    Nor can you select the text for a copy and paste.

    I have checked this in Firefox, safari and Opera - and all seems to be well - but internet explorer has this problem.

    Any ideas?

  2. #2
    Guru Meditation Error gnarly's Avatar
    Join Date
    Dec 2003
    Location
    Cheltenham, United Kingdom
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I think it may have something to do with the opacity filter on .content - try disabling that and see if it has any effect.
    Olly Hodgson
    thinkdrastic.net

  3. #3
    SitePoint Addict Tizer's Avatar
    Join Date
    May 2002
    Location
    Beach
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Bugger - it seems like you are right Thanks...

    So does anyone know of a work around for this?

    IE is a nightmare - everything I seem to do for it involves a workround - using the opacity filter was a work around for the transparent png background problem.

    Maybe I'll look for another work around

  4. #4
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You'll need to add position: relative to the element with the transparent background and maybe to the links too and possibly give them a higher z-index (I forget what the workaround is exactly but it definitely involves adding pos: relative to something).

  5. #5
    SitePoint Addict Tizer's Avatar
    Join Date
    May 2002
    Location
    Beach
    Posts
    306
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Well - its fixed

    It was a combination of adding pos: relative (thanks Tyssen) to my text div and then (wait for it) - changing the dimensions of my background image!!!

    I kid you not - mine were 10px x 10px and they are now 2px x 10px - you can find out more information on this png transparency article


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •