SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Feb 2006
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Very Strange IE Link Style Error

    If you look at the following link http://www.littlearth.com/classics_home.html in Firefox, all of my links look as they should.

    If you look at this very same page in IE, the links all inherit the nav div's bottom border.

    Even stranger is that further down, the visited links all change to the color of defined in the classicsContent div.

    I have never seen anything like this before, I don't even know what to call it if the issue has been addressed in a previous post. The page validates and I can't find possible parsing errors that could cause this. Does anyone have an idea?

  2. #2
    SitePoint Guru kish's Avatar
    Join Date
    Jun 2003
    Location
    UK
    Posts
    923
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    i don't see the problem :-S
    Fast Fwd Multimedia
    Web, IT & Cloud Computing Consultancy
    Currently looking for web freelancers. Get in touch!

  3. #3
    SitePoint Enthusiast
    Join Date
    Feb 2006
    Posts
    44
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    hmm thats odd. the visited link color up top is also appearing incorrect in Firefox.

    HTML Code:
    	
    #nav a:link, a:visited {
    	position: relative;
    	text-decoration: none;
    	padding: 0 0 3px 0;
    	margin: 0;
    	color: #878787;
    	border-bottom: 2px solid #878787;
    	}
    	
    #nav a:hover, a:active {
    	position: relative;
    	padding: 0 0 3px 0;
    	text-decoration: none;
    	margin: 0;
    	color: #333333;
    	border-bottom: 2px solid #333333;
    	}
    
    {
    This type is showing up incorrectly when the link is visited. The links, home, LE Classics, and LE Designer can be clicked on in the top nav. Click on one and you will see that the color changes to blue with a normal link underline. Even though, it is defined to keep the same properties as an unclicked link. When you rollover the visited link, the border shows up and the color displays properly. I'm not sure what the deal is.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •