SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Enthusiast
    Join Date
    Oct 2003
    Location
    Brussels
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Strange background behaviour, % of what ?

    I have here something I can't manage to find out.

    There are multiple absolute positioned divs, and the innermost of one set has this simple CSS rule applied to it :

    background:#F5F5F5 url(load.gif) no-repeat center fixed;

    The problem in FF and IE is the same, you would think that the background picture would be centered because 'center' was specified, but it's not the case !

    the background is behaving as if I used 60% from the left....

    and to achieve 'about' the right center position, i have to use

    background:#F5F5F5 url(load.gif) no-repeat 47% fixed;

    I know about some strange things when using percentages for positioning, be careful to know a percentage of what it will be and so on, but here, no clue at all...

    I'm not posting a sample right away because the problem is kinda buried in a lot of stuff, but well if it comes to it I can post something...

  2. #2
    SitePoint Enthusiast
    Join Date
    Oct 2003
    Location
    Brussels
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    up...

  3. #3
    SitePoint Enthusiast
    Join Date
    Oct 2003
    Location
    Brussels
    Posts
    30
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    both produce the same position which is not right, same if I put a div inside that one and try to center it, same result...


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •