SitePoint Sponsor

User Tag List

Results 1 to 3 of 3
  1. #1
    SitePoint Addict joyce's Avatar
    Join Date
    Aug 2001
    Posts
    295
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    missing value when passing through links.

    i passed these value from a link to page A

    PHP Code:
    admin.php?action=addRe&category_ID=$id 
    and then from page A i passed these values to page B.

    PHP Code:
    <a href=\"admin.php?action=writeRe&cat_ID=$category_ID\"><b>Write a review</b></a> 
    i did put hidden field but i can't get the cat_ID in page B. in the url, the cat_ID do have value but when i have this sql query:

    PHP Code:
    $sql "SELECT * FROM cat_review WHERE cat_ID = '$cat_ID'";
            
    $result mysql_query($sql);

            
    $record mysql_fetch_array($result); 
    cat_ID don't have any value. wat is wrong? pls help..

  2. #2
    SitePoint Guru
    Join Date
    Aug 2001
    Location
    Amsterdam
    Posts
    788
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Maybe if you post more of the code we can make something out of it but from this I don't get it either..

    Greets,

    Peanuts
    the neigbours (free) WIFI makes it just a little more fun

  3. #3
    ********* Callithumpian silver trophy freakysid's Avatar
    Join Date
    Jun 2000
    Location
    Sydney, Australia
    Posts
    3,798
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    You are using two different variables. In your url query string you are passing $category_ID but in your sql query you are using $cat_ID.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •