I was wondering if there's a javascript someone can make me or knows of one already made that can do the following:

1) Detect the users current version of flash.

2) If it detects 8 or lower to display in text, their version of flash on the page they're at and say "You're currently using the outdated flash player plugin version 2, The Flash Player Plugin is currently up to version 9 and is required for you to view the flash work on this page. Now is a good time to update your plugin. Click here to download it to have a better web experience."


Thanks ahead to anyone who can help me with this.
-Line