SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Wizard
    Join Date
    Jul 2003
    Location
    Kent
    Posts
    1,921
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)

    Firefox chokes on a suckerfish

    I thought I'd try the suckerfish menu and it all seemed to go quite well until I viewed it in FF, and it is missing half the styles - no borders, spacing altered dramatiaclly). Any suggestions are welcome on how to sort this.

    http://www.windrushers.org.uk/compet...regionals2006/

    It looks okay in IE6 (borders show okay, and spacing is okay) but is a little bit damaged in IE7, although I'm not bothered too much as the latter is beta software and it is pointless trying to cure something for a browser that will be altered in the near future.

    dr john

  2. #2
    SitePoint Wizard bronze trophy Tyssen's Avatar
    Join Date
    Oct 2005
    Location
    Brisbane, QLD
    Posts
    4,067
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Code:
    #nav a:link,  #nav a:visited,{
    Remove the extra comma after visited.

    Also, this:

    Code:
    <HTML xmlns="http://www.w3.org/1999/xhtml">
    should only be used with XHTML doctypes. You want <html> instead.

  3. #3
    SitePoint Wizard
    Join Date
    Jul 2003
    Location
    Kent
    Posts
    1,921
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Thanks!!

    It's interesting that I can always spot the extra or missing comma in someone else's work, but never in my own.

    thanks again.

  4. #4
    SitePoint Wizard
    Join Date
    Jul 2003
    Location
    Kent
    Posts
    1,921
    Mentioned
    1 Post(s)
    Tagged
    0 Thread(s)
    Any idea why the drop-downs have a small amount of white space at the end, with teh blue background color stopping short of the end of the block, and the rollover image is not at the end of the block? It does this in IE7 as well.

    Edit:
    Sorted the spare white space in the drop downs - a padding error.

    BUT
    Now the mousover for the last menu item (Images, to which no link yet exists) only shows the mouseover in FF if the mouse is placed very close to the left border of the I...!
    Last edited by Dr John; Jul 30, 2006 at 16:17.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •