SitePoint Sponsor

User Tag List

Results 1 to 5 of 5
  1. #1
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Italy
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    unordered-lists . . I'm stuck!

    Hi

    I'm laying a site out and I've run into a problem with the un-ordered lists. I have one for the navigation and another to display a thumbnail gallery. I started with Paul's horizontal drop down menu.

    with the nav up everything looked good as I wanted.
    http://experiments.poisson.it/Virtual/virtual2.html

    then I added the gallery and it picked up the ul and li formatting from the nav.
    http://experiments.poisson.it/Virtua...usgallery.html

    So I dropped the nav into a div and made the appropiate changes in the css, at least I thought I did. Now the nav stopped working in Explorer, though the gallery looks as it should with the exception of the first row which is slightly offset. http://experiments.poisson.it/Virtua...ixgallery.html

    can anybody tell me what I'm doing wrong? I can't figure out why menu stopped working in Explorer and the first row in the gallery is offset to the right.

    Thanks,
    Michael

  2. #2
    Caveat surfer Buddy Bradley's Avatar
    Join Date
    May 2003
    Location
    Cambridge, UK
    Posts
    2,366
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Code:
    #gallery ul {
      padding: 0;
    }

  3. #3
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Italy
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    thanks buddy bradley

    that fixed the gallery up!!

    unfortunately the menu still doesn't drop down in explorer.

    thanks again,
    Michael

  4. #4
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Italy
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    actually all the mouse over effects have broken in explorer . . . . . not only has the drop down menu stopped working but the background color doesn't change on any of the links. I can't figure out what is with the gallery code that has created a conflict with the menu
    Last edited by poisson; Jul 28, 2006 at 10:19.

  5. #5
    SitePoint Enthusiast
    Join Date
    Mar 2002
    Location
    Italy
    Posts
    32
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I'm getting closer . . . it's not a conflict with the gallery but rather a problem puting the navigation into a div. I started again with paul's menu (http://www.pmob.co.uk/temp/dropdown_horizontal2.htm) which I published here http://experiments.poisson.it/Virtual/prova.htm

    then I dropped the navigation into a div


    <div id="nav">
    <ul >
    <li><a href="#">Home</a></li>
    <li><a href="#">About</a>
    <ul>
    <li><a href="#">History</a></li>
    <li><a href="#">Team</a></li>
    <li><a href="#">Offices</a></li>
    </ul>
    </li>
    <li><a href="#">Services</a>
    <ul>
    <li><a href="#">Web Design</a></li>

    <li><a href="#">Internet Marketing</a></li>
    <li><a href="#">Hosting</a></li>
    <li><a href="#">Domain Names</a></li>
    <li><a href="#">Broadband</a></li>
    </ul>
    </li>
    <li><a href="#">Contact Us</a>
    <ul>

    <li><a href="#">United Kingdom</a></li>
    <li><a href="#">France</a></li>
    <li><a href="#">USA</a></li>
    <li><a href="#">Australia</a></li>
    </ul>
    </li>
    </ul>
    </div>

    finally I made some changes to the styles in new file for comparison http://experiments.poisson.it/Virtual/prova2.htm
    was, example;


    ul {
    margin: 0;
    padding: 0;
    list-style: none;
    }

    ul li {
    position: relative;
    float: left;
    width:149px;
    }

    now;


    #nav ul {
    margin: 0;
    padding: 0;
    list-style: none;
    }

    #nav ul li {
    position: relative;
    float: left;
    width:149px;
    }

    however the menu stops working in explorer though it is just fine in firefox.

    I think I'm overlooking something obvious.

    Anybody have an idea?

    thanks,
    Michael


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •