SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    SitePoint Zealot
    Join Date
    Jan 2003
    Posts
    143
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    CSS z-index not working

    On a site i've worked on, i have a drop-down menu, which works fine except on pages with embeded video, where the menu goes behind the video.

    the video is in it's own div with a z-index of 80, while the drop down menu has a z-index of 1000

    example page: http://www.voxpops.com/screen2.php?v...9_VPISR_InfoAd

    css: http://www.voxpops.com/voxpop2.css

    Any help would be much appreciated.

  2. #2
    The CSS Clinic is open silver trophybronze trophy
    Paul O'B's Avatar
    Join Date
    Jan 2003
    Location
    Hampshire UK
    Posts
    40,492
    Mentioned
    182 Post(s)
    Tagged
    6 Thread(s)
    Hi,

    Its working in ie but I don't think you will be able to solve this for other browsers unless you resort to some javascript.

    See the following links for more info.

    http://dotnetjunkies.com/WebLog/jkin...07/21/488.aspx

    and here.

    and google for iframe shim.

    Also note that z-index only has effect on positioned elements so yyou need to seta position:relative (without co-ordinates) if the element isn't position:absolute already. However that has nothing immediatley to do with your problem.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •