SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Jun 2006
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Exclamation VERY STRANGE browser bug

    Hello everyone!

    I've searched the web, and have never heard of the behavior that I somehow inadvertently created! I hope someone out there can help me??

    Basically, I'm not sure if this is my CSS/HTML or the browsers' bug, but here goes: apparently if you use the back browser button to navigate instead of the navbar, the mouseover image "sticks" to the navbar even after the navbar has changed "modes" to the next section. Easiest for you to try and see to understand:

    for the below example, here is the link: www.productionsync.com/caption/
    here is the CSS, if it will help: http://www.productionsync.com/caption/css/styles_fw.css

    , To reproduce the bug
    (1) Click one of the main menu items (e.g. Services)
    (2) Then click a different menu item (e.g. About Us)
    (3) Then use the browser back arrow (to go back to Services).

    Observed: (see screenshot_bug.jpg, attached)


    The mouseover image is stuck on About Us. In Win IE it really gets stuck, you have to reload the page to fix it, the others seem to fix themselves if you mouseover About Us.

    Expected: (see screenshot_normal.jpg, attached)

    This seems to happen on all browsers on both PC/Mac.... can anyone PLEEZ help me?

    thanks!
    ian
    Attached Images Attached Images

  2. #2
    SitePoint Addict
    Join Date
    Mar 2005
    Location
    Toronto
    Posts
    378
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Hmm for me, it seems to behave right for FF, there is no problem. As of IE, the only problem is that the previously selected item would still be on focus when use back to navigate, but the state changes back to normal when you click on somewhere else on the webpage.
    In search of the clouds...and maybe some work

  3. #3
    SitePoint Member
    Join Date
    Jun 2006
    Posts
    18
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    ie and back browser button compatibility??

    thanks kefeso,

    thanks to your reply, I think I figured out what the problem is, I just now need a solution!

    so I have a new question!

    It basically has to do with the “a:focus, and a:active” states that I added to the CSS for IE and keyboard accessibility... Basically I think what’s happening is that using the back browser button does tell the browser to go back to the previous page, but when it loads the page, it still “keeps” the “last clicked” navbar item in its “hover/active/focus” state ( you can see the menu item outlined slightly) even if the mouse is not technically over it.

    When I got rid of the “a:focus and a:active” rules in the CSS, this bug, for the most part, went away, but then there goes the accessibility... Is there some way to keep the a:active/focus rules that works around the back browser button issue?

    Thanks again,
    ian

  4. #4
    SitePoint Addict Feliciaf's Avatar
    Join Date
    Mar 2004
    Location
    New Zealand
    Posts
    385
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Read this little handy piece and it may help:
    http://leftjustified.net/site-in-an-hour/

    Basically, IE/PC does not render the :focus pseudo-class, but it does treat :active as :focus. It may help to put them in a specific order according to this tutorial...

    Hope this helps.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •