SitePoint Sponsor

User Tag List

Results 1 to 4 of 4
  1. #1
    SitePoint Member
    Join Date
    Dec 2004
    Location
    Dallas, TX
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)

    Yet another IE style problem: tabs missing edges

    If you visit www.realtybaron.com with IE, you'll see the tops of the tabs "shaved" off. Why is this happening?

  2. #2
    Guru Meditation Error gnarly's Avatar
    Join Date
    Dec 2003
    Location
    Cheltenham, United Kingdom
    Posts
    692
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    I have a feeling it's because your <a> elements aren't block level. Try adding display:block; to #tabnav a
    Olly Hodgson
    thinkdrastic.net

  3. #3
    SitePoint Member
    Join Date
    Dec 2004
    Location
    Dallas, TX
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by gnarly
    I have a feeling it's because your <a> elements aren't block level. Try adding display:block; to #tabnav a
    Thanks for the input. Unfortunately, that did not work. The tabs grew the width of the screen and stacked on top of each other as a result

  4. #4
    SitePoint Member
    Join Date
    Dec 2004
    Location
    Dallas, TX
    Posts
    8
    Mentioned
    0 Post(s)
    Tagged
    0 Thread(s)
    Quote Originally Posted by gnarly
    I have a feeling it's because your <a> elements aren't block level. Try adding display:block; to #tabnav a
    Hey, you were right! I added display:block to the #tabnav instread of #tabnav a and my tabs are showing almost correctly. Now, the bottom border on the "active" tab is showing in IE when it shouldn't.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •