SitePoint Sponsor

User Tag List

Results 1 to 2 of 2
  1. #1
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,606
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)

    hidden value not displaying contents correctly.

    Code:
    <input type="hidden" id="MyEditor" name="MyEditor" value="<p>Greetings!</p>
    <p>Intro</p>
    <p>For anyone who's considering system upgrades, AMD has slashed prices on a number of their CPUs</p>
    <p>&nbsp;</p>
    <p>If you're still a little bit confused about what Net Neutrality is and how it applies to you as a surfer of cyberspace, take a look at this article where Net Neutrality is put into terms of <a href="http://www.frankston.com/Public/Default.aspx?zz=xcs&amp;Script_name=%2Fdefault.aspx&amp;name=Sidewalks">your right to walk down a street sidewalk</a>.</p>" />
    I'm trying to display this code using FCKeditor (an HTML editor box, something like what's found on the forums here for posting). The problem is the hidden value isn't handling the code right. It seems to close the "value" attribute as soon as it sees a double quote, like the one found in the link tag.

    How do I get it so that those double quotes will be ignored so that everything is included in the hidden value?

    [edit]: here's a screenshot of what displays in IE6: http://img130.imageshack.us/img130/5...keditorer4.jpg

  2. #2
    Barefoot on the Moon! silver trophy Force Flow's Avatar
    Join Date
    Jul 2003
    Location
    Northeastern USA
    Posts
    4,606
    Mentioned
    56 Post(s)
    Tagged
    1 Thread(s)
    Nevermind...I figured it out.

    The double quotes need to be replaced with the &quot; symbol.


Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •